inca tech claymore mk3 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th May 2010, 03:33 PM   #1
Account disabled at member's request
 
Join Date: Aug 2008
Default inca tech claymore mk3

Hi, I bought the above off ebay last week as spares/ repair, Kinda knew what i was letting myself in for, Until i had a proper look inside. As you can see its a bit of a mess from a previous bodge exponents attempt Ive searched the web with little to go on, PCB tracks are broken wrong value components etc, Not good! Main problem is the arrowed broken track havent a clue where it should end up, Anyone either got a mk3 or has a schematic or dia of the output circuitry, or, insight, gratefully received!

Thanks for any help,


Apologies for fuzzy pics, But you get the idea!

regards.
Attached Images
File Type: jpg P160510_16.03.jpg (88.9 KB, 265 views)
File Type: jpg P160510_16.03_[01].jpg (78.2 KB, 245 views)
File Type: jpg P160510_16.05_[01].jpg (49.0 KB, 230 views)
  Reply With Quote
Old 16th May 2010, 06:47 PM   #2
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
There's nothing like a challenge is there for you not me

I would note what seems to go where, wash the PCB and chassis with foam cleaner to get rid of all the gunge and then see what's what.

I see K413 which looks like 2SK413 so it's a FET output... 2SK413/2SJ18 are a bit unique... laterals won't work directly.

Fixing the broken print... trace the supplies to the outputs... those two commoned resistors might be to the output... normal source follower output rather than cfp.

Getting the original outputs will be the issue I suspect. Out of interest just what has been put in for those ?
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote
Old 17th May 2010, 01:29 AM   #3
Account disabled at member's request
 
Join Date: Aug 2008
2sk1058 and 2sj162

Its junk, But good old....

Colin Wonfor . explain yeself NAI!

Last edited by rocco gibralter; 17th May 2010 at 01:48 AM.
  Reply With Quote
Old 17th May 2010, 06:19 AM   #4
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Good luck with it then
the 1058/162 won't work

Colin Wonfer ?????? that's a name from the past, I remember some of his articles in Wireless World, and the criticism that followed by a certain D Self.
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote
Old 17th May 2010, 02:45 PM   #5
Account disabled at member's request
 
Join Date: Aug 2008
Thanks Mooly, Yeah ive read a few disingenuous articles regarding Colin, Its ppl like him who put british Hi'fi on the map..made it infamous etc?

In two minds whether to bother with the claymore now, Its been under the knife too many times, The orig fets are daft money if you can get them? and even if all's well it'll still go pop again at some point... tis the nature of the beast!

Might stick a set of IRFP9240 & IRFP240's and some fresh .47r's in it fix the tracks, crank up the 60w bulb... see how it blows!
  Reply With Quote
Old 17th May 2010, 05:37 PM   #6
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Well good luck with it whatever you decide
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote
Old 6th June 2010, 06:05 PM   #7
Account disabled at member's request
 
Join Date: Aug 2008
Hi Mooly, Spent the whole day working on it, Finally done with a few mods, Heatink, and remotely wired mosfets, Even with a solder wick the tracks were coming loose Makes for an easier time if it goes pop ever again, Not happy about the new position of the traffo, but no'where else so have to see how it hums?

Heads fried, so wont test it tonight, I'm gonna go sit outside the pub and have a few cold beers instead!! tomorrow is another day!
Attached Images
File Type: jpg P060610_18.44.jpg (627.1 KB, 151 views)
File Type: jpg P060610_18.45.jpg (581.6 KB, 129 views)

Last edited by rocco gibralter; 6th June 2010 at 06:09 PM.
  Reply With Quote
Old 6th June 2010, 06:19 PM   #8
Mooly is offline Mooly  United Kingdom
diyAudio Moderator
 
Mooly's Avatar
 
Join Date: Sep 2007
Fingers crossed then

If you haven't already powered it up yet, maybe use a 100 watt bulb in series with the mains... just to be sure
__________________
-------------------------------------------------------
Installing and using LTspice. From beginner to advanced.
  Reply With Quote
Old 27th November 2010, 11:32 AM   #9
Root2 is offline Root2  United Kingdom
diyAudio Member
 
Root2's Avatar
 
Join Date: Nov 2010
Location: Somerset
Default Claymore 2 not 3

Quote:
Originally Posted by rocco gibralter View Post
2sk1058 and 2sj162

Its junk, But good old....

Colin Wonfor . explain yeself NAI!
Hi Rocco, What do I need to explain, that some twit has messed the PCB up, or do you want circuits, part are harder to find now but if I can help I will.

Regards

The Infamous

Colin J. Wonfor (not Wonfer they are not related)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Inca Tech Claymore Vol. Pot. danza Solid State 14 17th May 2014 08:29 AM
FS - Inca Design Katana SE CD Player powershot Swap Meet 1 27th February 2011 09:05 PM
Inca Design Katana problem.. audio1st Digital Source 6 26th October 2007 12:50 PM
Why triode Mk3 is louder than stock Mk3 Wieslaw Lipowsk Tubes / Valves 5 14th June 2007 01:18 PM
Inca Designs 75 power amp chrisbp Solid State 2 20th January 2007 09:30 AM


New To Site? Need Help?

All times are GMT. The time now is 03:30 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2