HEEEELLLPPP : M. Randy Slone Mirror Image Topology Construction - Troubles - Page 28 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th December 2010, 12:18 PM   #271
diyAudio Member
 
Join Date: Dec 2009
Location: Brussels
Hi Wahab,
I will post schematics, pictures of the pcb, scope trace pictures, etc... this evening (that is GMT+1 evening) but most probably it will be tomorrow.
Thnx already...
Olivier
  Reply With Quote
Old 17th December 2010, 08:56 PM   #272
diyAudio Member
 
Join Date: Dec 2009
Location: Brussels
Hello,
Here are the files of my latest trial... with only limited succes i must say.
The files contain the schematic, dc analyses for currents & voltages, the AC analyses, some pictures of the PCB and some pictures of the scope image.

The schematic & pcb do not contain any OPS yet. The VAS output is returned to the IS via the feedback layout.

First of all, looking at the AC analyses I don't like the bandwidth to be so large. Especially in the HF region. But trying to bring it lower I end up with millercaps nearing 1nF !? That seems outrageously large. This will suffocate my IS right?
If you look at the AC analyses bear in mind the black line is the one OUTPUT/INPUT at the base of diff amps. The green one is the ratio between the BASES of the diff amps feedback side and the BASES of the diff amp input side. The red one is output / input source (off course this one looks nice because the low and high freq rolloffs are set by the input conditionning circuit. But anyway the BLACK one is the internal one ... (i don't know if the green one is of any value?)

Secondly I find it odd that the output signal suddenly at 149KHZ changes from looking good to looking bad AND mostly on the negative side not on the positive side or much less. Why? What causes this behavior?

As I said in my previous mail you can read just above ... at 850KHZ or so the trace goes into RF oscillation I guess... just buzzing and bouncing around

Maybe you guys can do something with the square behavior ... see pictures too....

Please I need help as my knowledge is alas limited ... I know the basics and a bit more but I am not a wizard like some of you ...

Lets what you guys come up with?

rest of the pics in the next post

thnx

Olivier
Attached Images
File Type: jpg PCB1.JPG (91.1 KB, 154 views)
File Type: jpg PCB2.JPG (94.6 KB, 153 views)
File Type: jpg 1KHZ_BLOK.JPG (98.0 KB, 142 views)
File Type: jpg 1KHZ_SINUS.JPG (96.6 KB, 129 views)
File Type: jpg 100KHZ_BLOK.JPG (97.6 KB, 125 views)
File Type: jpg 100KHZ_SINUS.JPG (98.5 KB, 32 views)
Attached Files
File Type: pdf IS and VAS AC analyses.pdf (122.9 KB, 25 views)
File Type: pdf IS and VAS DC analyses currents.pdf (26.9 KB, 13 views)
File Type: pdf IS and VAS DC analyses voltages.pdf (23.5 KB, 15 views)
File Type: pdf IS and VAS schematic.pdf (20.6 KB, 42 views)
  Reply With Quote
Old 17th December 2010, 08:57 PM   #273
diyAudio Member
 
Join Date: Dec 2009
Location: Brussels
Default sequel

the rest ...
Attached Images
File Type: jpg 146KHZ_SINUS.JPG (97.8 KB, 28 views)
File Type: jpg 149KHZ_SINUS.JPG (98.6 KB, 24 views)
File Type: jpg 150KHZ_BLOK.JPG (97.4 KB, 22 views)
File Type: jpg 150KHZ_SINUS.JPG (97.8 KB, 27 views)
  Reply With Quote
Old 17th December 2010, 09:45 PM   #274
Leon08 is offline Leon08  Germany
Banned
 
Join Date: Sep 2010
Location: at Home
Hello.
As I can see it beginns to be unstable at 150kHz.But I think it's not a big problem because audio signals are going only to 20kHz.With an input filter should be no problem.And You set your current sources for 6.25mA.I think it's too much.Try to reduce it and see what happens.I think 4mA is a good value to beginn with.

Last edited by Leon08; 17th December 2010 at 09:58 PM.
  Reply With Quote
Old 21st December 2010, 01:29 PM   #275
diyAudio Member
 
Join Date: Dec 2009
Location: Brussels
Default update

Hi there,
Since the last post there are some updates.
Hereby the schematc as it is built right now (after further testing).
What changed?
1) I removed the input HF filter capacitor Cin2 because I wanted to measure the AC response of the amp without the filter up front. I worried this would render it unstable since i allow VHF injections at the input. I was affraid it picked up RF noise.... but no it doesn't.
2) I reinserted the TMC compensation instead of a single miller cap. While this was not realy the intention it is there now because I soldered and unsoldered so many times so many components to check the behavior. Maybe I will remove it again soon to go back to a single miller cap (when i do i will let it know)
3) What helped quite a bit was removing R105, R106, C101 and C102. I don't know their purpose very well? It is part of the CMCL so it should be DC related only. While it does not change anything to my DC settings it made the amp less vulnerable to RF oscillations. If the have no important purpose I would rather skip them (but then again I ignore their purpose so.. anyone could tell? The caps are quite big 470nF so I gues it's lpow freq related?
4) I removed cap C900 & C901 it did not change anything as far as i can notice....
5) CFB2 is reduced from 10pF to 5,6pF ... I don't really know if this chnged much because often one probleme covers another and nested errors lead you to believe it doesn't change a thing while at that moment it is not because a bigger phenomen is lying on top swamping it's behavior ...
6)CFB1 is set to 470u instead of 3x times this value because i soldered only 1 cap instead of three however this is only impacting on the LF rolloff point tight?
7)My QCC1&2 are replaced by another type since I blew the last two ... It is now type : 2SC5171 & 2SA1930. They are slightly higher power Q's but have a bit more Cap and a bit lower FT. For the rest I guess it's not critical since they are just cascodes.

I send the schematic as it is build here in front of me ....
Also AC analyses,DC voltages and currents...
+ pictures of
-> output without input
-> pcb topview
-> 100KHZ sinewave
-> picture of each increment of 10kHz and further on larger steps.
-> Up until 10MHz maximum for my function generator.
-> Last picture = at 10MHz input and output signal. Output is stil twice the input signal or +6dB amplified.

What do you see?

I see good respo,nse till around 130KHZ where the sinewave starts to show bumps in the curve. This gets worse till a point around 250-300KHZ where the trace also starts to become shaky showing oscillations (RF?) ... afterwards the sinewave looks more and more to a sine again over 1MHz it is nearly a perfect sine -> look at 10MHZ it looks a perfect sine (why??)

My 2 major curiosities are :

A) the sudden bumps in the trace at 130KHZ why so sudden? It is a bump but it looks clear on the scope I mean it's not shakyness ... Why is that.???

B) The shakiness at 250-300KHZ i guess here it is an internal stability issue somewhere in the schematic / pcb .... but why does it go away further up the freq?

OK I gotta go now ... wife is already waiting in the car
She :

Ideas?

Olivier
Attached Images
File Type: jpg PCB Top View.JPG (93.9 KB, 35 views)
File Type: jpg No Input.JPG (97.3 KB, 36 views)
Attached Files
File Type: pdf CMCL_20_TMC&TPC_AsBuilt2_Voltages.pdf (23.2 KB, 16 views)
File Type: pdf CMCL_20_TMC&TPC_AsBuilt2_Currents.pdf (26.4 KB, 9 views)
File Type: pdf CMCL_20_TMC&TPC_AsBuilt2.pdf (20.3 KB, 17 views)
File Type: pdf AC Analysis_as built2.pdf (142.4 KB, 15 views)
  Reply With Quote
Old 21st December 2010, 01:30 PM   #276
diyAudio Member
 
Join Date: Dec 2009
Location: Brussels
Default update (followed)

the pictures
Attached Images
File Type: jpg 100.JPG (93.7 KB, 24 views)
File Type: jpg 110.JPG (101.8 KB, 12 views)
File Type: jpg 120.JPG (95.9 KB, 11 views)
File Type: jpg 130.JPG (99.0 KB, 8 views)
File Type: jpg 140.JPG (94.6 KB, 8 views)
File Type: jpg 150.JPG (97.2 KB, 9 views)
File Type: jpg 160.JPG (97.0 KB, 5 views)
File Type: jpg 170.JPG (99.6 KB, 8 views)
File Type: jpg 180.JPG (96.4 KB, 9 views)
File Type: jpg 190.JPG (98.4 KB, 10 views)
  Reply With Quote
Old 21st December 2010, 01:31 PM   #277
diyAudio Member
 
Join Date: Dec 2009
Location: Brussels
Default update (followed2)

...
Attached Images
File Type: jpg 200.JPG (98.6 KB, 10 views)
File Type: jpg 210.JPG (94.7 KB, 5 views)
File Type: jpg 220.JPG (90.1 KB, 3 views)
File Type: jpg 230.JPG (86.7 KB, 4 views)
File Type: jpg 240.JPG (96.6 KB, 4 views)
File Type: jpg 250.JPG (100.6 KB, 5 views)
File Type: jpg 260.JPG (96.3 KB, 3 views)
File Type: jpg 270.JPG (97.6 KB, 4 views)
File Type: jpg 280.JPG (95.6 KB, 4 views)
File Type: jpg 290.JPG (96.8 KB, 7 views)
  Reply With Quote
Old 21st December 2010, 01:33 PM   #278
diyAudio Member
 
Join Date: Dec 2009
Location: Brussels
Default update (followed3)

...
Attached Images
File Type: jpg 300.JPG (94.6 KB, 11 views)
File Type: jpg 320.JPG (97.5 KB, 9 views)
File Type: jpg 330.JPG (98.1 KB, 6 views)
File Type: jpg 340.JPG (99.4 KB, 4 views)
File Type: jpg 350.JPG (92.7 KB, 5 views)
File Type: jpg 360.JPG (101.4 KB, 3 views)
File Type: jpg 370.JPG (100.4 KB, 4 views)
File Type: jpg 380.JPG (98.0 KB, 3 views)
File Type: jpg 400.JPG (97.0 KB, 3 views)
File Type: jpg 450.JPG (92.2 KB, 7 views)
  Reply With Quote
Old 21st December 2010, 01:35 PM   #279
diyAudio Member
 
Join Date: Dec 2009
Location: Brussels
Default update (followed4)

...
last one

IF SOMEONE WANTS THE SQUAREWAVE RESPONS PLEASE LET ME KNOW
(ALL FREQ? SOME FREQ?)

THNX

OLIVIER
Attached Images
File Type: jpg 800.JPG (93.4 KB, 9 views)
File Type: jpg 1000.JPG (88.7 KB, 10 views)
File Type: jpg 4000.JPG (93.1 KB, 11 views)
File Type: jpg 10000.JPG (94.0 KB, 9 views)
File Type: jpg 10000_I&O.JPG (100.0 KB, 8 views)
  Reply With Quote
Old 21st December 2010, 02:47 PM   #280
Leon08 is offline Leon08  Germany
Banned
 
Join Date: Sep 2010
Location: at Home
It's a good working amplifier IMHO.This instability at 250-300KHZ is caused by some parasitic inductances, I think.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Randy Slone 6.6 design py Solid State 8 20th July 2011 02:06 PM
Randy Slone Passes Bluetron Solid State 51 8th January 2011 10:05 AM
Randy Slone JDDCo Solid State 6 22nd September 2006 02:57 AM
Randy Slone: Opti-MOS pixie Solid State 73 12th September 2004 07:57 AM
OPTIMOS-Amp from Randy Slone wopo Solid State 1 12th July 2004 08:18 PM


New To Site? Need Help?

All times are GMT. The time now is 12:37 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2