JBL 518S amplified subwoofer system - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th April 2010, 11:57 PM   #1
diyAudio Member
 
Join Date: Jan 2008
Default JBL 518S amplified subwoofer system

I just bought one of these JBL 518S amped speakers. The 2nd time I turned it on, the blue LED flashes once instead of staying lit. What could be the reason? The AC supply of the wall outlet is well above 100V as stated in the manual as minimal power requirement. And the first time I powered it up at the same wall outlet it worked.

Phantombox
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
JBL W15GTi subwoofer for sale John Sheerin Swap Meet 3 31st January 2011 09:56 PM
3 Way system with JBL 2213H Amblifier Multi-Way 2 24th April 2007 07:30 PM
how to connect a non powered subwoofer to a stereo system without a subwoofer output JSD777 Multi-Way 4 20th September 2005 04:19 PM
Problem with JBL speaker system John Hope Car Audio 2 3rd June 2005 02:31 PM
Infinity BU1 amplified subwoofer. problems. pat allen Solid State 0 30th December 2004 03:42 PM


New To Site? Need Help?

All times are GMT. The time now is 05:18 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2