gk 800rb probs - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th April 2010, 06:10 PM   #1
diyAudio Member
 
Join Date: Apr 2010
Default gk 800rb probs

Hi Folks,

I have a GK800 RB that's been completely faithful for years. Never abused, always plugged in to 8 ohms. Suddenly it is making a rude distortion sound. I suspect the problem may be in either the frequency pot, the bi-amp push-pull switch, or in whatever circuit they share (which may be the whole amp for all I know).

I suspect this because the frequency pot generates popping sounds when turned, especially to its extremities, and the push-pull switch is full of static-like noise. None of the other pots or switches is a problem.

I'm wondering if I should just replace the whole board.

Appreciate any help.
  Reply With Quote
Old 11th April 2010, 11:12 PM   #2
diyAudio Member
 
Join Date: Mar 2009
lots of GK info here Audio GallienKrueger : Service Manual free download,schematics,datasheets,eeprom bins,pcb,repair info for test equipment and electronics

Is the distortion in the line out, or DI out, if so, the distortion is from the pre amp, otherwise from the power amp.
Start at the input, trace teh signal through the amp, once you find which section is distorting, you can fix it.
If you are not sure, maybe an amp tech is your best bet
  Reply With Quote
Old 12th April 2010, 12:48 AM   #3
diyAudio Member
 
Terry Demol's Avatar
 
Join Date: Apr 2002
Location: *
Quote:
Originally Posted by flatarchtop View Post
Hi Folks,

I have a GK800 RB that's been completely faithful for years. Never abused, always plugged in to 8 ohms. Suddenly it is making a rude distortion sound. I suspect the problem may be in either the frequency pot, the bi-amp push-pull switch, or in whatever circuit they share (which may be the whole amp for all I know).

I suspect this because the frequency pot generates popping sounds when turned, especially to its extremities, and the push-pull switch is full of static-like noise. None of the other pots or switches is a problem.

I'm wondering if I should just replace the whole board.

Appreciate any help.
In addition to above suggestions check main PS - return. Some GK's use
rear speaker 1/4" jack connector as the return point and if it works loose
can cause a problem.

cheers

Terry
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
need help with gallien krueger 800rb dkdeleon Solid State 19 3rd June 2010 09:27 PM
Gk-71 Vladi59 Swap Meet 0 23rd March 2009 05:02 PM
Blown up GK 800rb mpm32 Instruments and Amps 1 13th April 2007 09:20 PM
Capacior leak on my GK 800RB jeyvi Solid State 5 26th December 2005 09:46 AM


New To Site? Need Help?

All times are GMT. The time now is 06:46 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2