500W PA amplifier with Limiter - Page 141 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th March 2011, 06:37 AM   #1401
diyAudio Member
 
Join Date: Apr 2005
Location: davao city
Quote:
Originally Posted by viki_v2 View Post
I am using low power transformer , could that be the reason.
I have checked the tracks continuity, Its fine.
whats the voltage you used?
  Reply With Quote
Old 27th March 2011, 06:50 AM   #1402
viki_v2 is offline viki_v2  India
diyAudio Member
 
viki_v2's Avatar
 
Join Date: Feb 2009
Location: India (Mumbai)
i did it, i checked each and every pin for shorts and cold solders, there were 2 shorts at mje340 and 15032, i cleared them, still the problem persists.
  Reply With Quote
Old 27th March 2011, 06:52 AM   #1403
viki_v2 is offline viki_v2  India
diyAudio Member
 
viki_v2's Avatar
 
Join Date: Feb 2009
Location: India (Mumbai)
Quote:
Originally Posted by jalou1995 View Post
whats the voltage you used?
24-0-24 3 amperes, after rectification it is 37-0-37.
  Reply With Quote
Old 27th March 2011, 06:52 AM   #1404
diyAudio Member
 
Join Date: Aug 2009
Maybe fake, some transistors?
  Reply With Quote
Old 27th March 2011, 06:53 AM   #1405
viki_v2 is offline viki_v2  India
diyAudio Member
 
viki_v2's Avatar
 
Join Date: Feb 2009
Location: India (Mumbai)
Quote:
Originally Posted by Josip_Del View Post
Maybe fake, some transistors?
not at all, all are original toshiba trannies.
  Reply With Quote
Old 27th March 2011, 07:06 AM   #1406
diyAudio Member
 
aman khalsa's Avatar
 
Join Date: Oct 2010
Location: punjab
post some more pics bro....
  Reply With Quote
Old 27th March 2011, 07:00 PM   #1407
viki_v2 is offline viki_v2  India
diyAudio Member
 
viki_v2's Avatar
 
Join Date: Feb 2009
Location: India (Mumbai)
Quote:
Originally Posted by aman khalsa View Post
post some more pics bro....
Check the pics and guide.
Attached Images
File Type: jpg DSC_0055.JPG (275.7 KB, 946 views)
File Type: jpg DSC_0056.JPG (384.1 KB, 851 views)
File Type: jpg DSC_0057.JPG (357.3 KB, 740 views)
File Type: jpg DSC_0062.JPG (242.0 KB, 677 views)
File Type: jpg DSC_0065.JPG (355.6 KB, 633 views)
File Type: jpg DSC_0066.JPG (440.7 KB, 140 views)
File Type: jpg DSC_0067.JPG (437.2 KB, 136 views)
File Type: jpg DSC_0068.JPG (369.9 KB, 164 views)
  Reply With Quote
Old 27th March 2011, 08:22 PM   #1408
diyAudio Member
 
Join Date: Mar 2011
Location: jakarta
it is real 500w rms? can anybody tell me?
  Reply With Quote
Old 28th March 2011, 02:25 AM   #1409
diyAudio Member
 
irvynejay's Avatar
 
Join Date: Nov 2010
Location: Philippines;Mindanao,Butuan
Send a message via Yahoo to irvynejay Send a message via Skype™ to irvynejay
Default Grounding

I can't see input ground to PSU did you follow this?
Attached Images
File Type: jpg DSC_0067.JPG (583.3 KB, 160 views)
File Type: jpg APEX GND Wireing.jpg (83.5 KB, 171 views)

Last edited by irvynejay; 28th March 2011 at 02:27 AM.
  Reply With Quote
Old 28th March 2011, 04:02 AM   #1410
diyAudio Member
 
electra_ina's Avatar
 
Join Date: Mar 2009
Location: Near Jakarta
Hi..Viki.. I see your B500..that original resistor 47K (red code), but applied 4K7..is wrong..this picture:
Click the image to open in full size.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
900W H-class PA Amp with Limiter apexaudio Solid State 2993 19th July 2014 07:50 PM
500w power amplifier juneray Solid State 70 16th September 2011 04:05 PM
500W Power Amplifier JRdGreat Solid State 24 16th September 2009 09:48 AM
500W Aleph Amplifier? lscangus Pass Labs 20 19th November 2005 08:29 PM
Looking for 300-500W amplifier audioPT Solid State 3 31st August 2002 12:39 PM


New To Site? Need Help?

All times are GMT. The time now is 06:44 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2