500W PA amplifier with Limiter - Page 133 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st February 2011, 04:10 AM   #1321
gwendy is offline gwendy  Indonesia
diyAudio Member
 
gwendy's Avatar
 
Join Date: Mar 2010
Location: Toraja
Quote:
B500 with balanced input, volume pot and bias adjust.
Attached Thumbnails Click the image to open in full size.
nice work sir, I am waiting for your latest PCB design for this B500
  Reply With Quote
Old 21st February 2011, 08:03 AM   #1322
diyAudio Member
 
Join Date: Apr 2010
Location: HARARE
CAN YOU SEND THIS PROTECT CCT ON MY E-MAIL ptinarwo@sirdc.ac.zw i am finalising my B500 AMP. thank you
  Reply With Quote
Old 21st February 2011, 08:13 PM   #1323
diyAudio Member
 
apexaudio's Avatar
 
Join Date: Feb 2010
Location: Serbia
Quote:
Originally Posted by gwendy View Post
nice work sir, I am waiting for your latest PCB design for this B500
I cosidering to add signal led, fan control, VI limiter, triple darlington...
  Reply With Quote
Old 21st February 2011, 09:18 PM   #1324
gwendy is offline gwendy  Indonesia
diyAudio Member
 
gwendy's Avatar
 
Join Date: Mar 2010
Location: Toraja
Quote:
I cosidering to add signal led, fan control, VI limiter, triple darlington
more complete and the wiring will be more modest, thank you sir
  Reply With Quote
Old 22nd February 2011, 12:51 PM   #1325
viki_v2 is offline viki_v2  India
diyAudio Member
 
viki_v2's Avatar
 
Join Date: Feb 2009
Location: India (Mumbai)
Hello,
i am not able to get 24 v 16a relay for protect pcb. Can any one help.
if any members from India have got it, kindly guide where to purchase it.
  Reply With Quote
Old 23rd February 2011, 05:17 PM   #1326
yohnsee is offline yohnsee  Hungary
diyAudio Member
 
Join Date: Jul 2010
Location: Bekescsaba
Default A little help please

Hy Apex! Please help me! I measured the amp last time before i pack it together, and one of the panels show 0.3V dc offset! The other one is fine, that is 0.2mV. How could I start to measure and where? Would it help if I post pictures?
Thanks in advance
__________________
The bird is the word...
  Reply With Quote
Old 23rd February 2011, 09:36 PM   #1327
diyAudio Member
 
apexaudio's Avatar
 
Join Date: Feb 2010
Location: Serbia
Quote:
Originally Posted by yohnsee View Post
Hy Apex! Please help me! I measured the amp last time before i pack it together, and one of the panels show 0.3V dc offset! The other one is fine, that is 0.2mV. How could I start to measure and where? Would it help if I post pictures?
Thanks in advance
Measure voltage on Z1, Z2 and R20, R21. Do you measure BIAS?
  Reply With Quote
Old 24th February 2011, 06:17 AM   #1328
yohnsee is offline yohnsee  Hungary
diyAudio Member
 
Join Date: Jul 2010
Location: Bekescsaba
Quote:
Originally Posted by apexaudio View Post
Measure voltage on Z1, Z2 and R20, R21. Do you measure BIAS?
Hy! I measured BIAS, it's 30-35mA in cold state for both panels. I will make the other measures as i get home from work. Do i have to measure voltage between power gnd and Z1, Z2, R20, R21?
And one more thing: I didn't connect POWER GND to SIGNAL GND, can it be the problem? But if yes, why has one of the panels 7mV DC offset (i measured it again) and the other 300mV? I can't figure it out.
Any ideas are welcome.
__________________
The bird is the word...
  Reply With Quote
Old 24th February 2011, 03:36 PM   #1329
diyAudio Member
 
Join Date: Oct 2009
urgent
for two pairs of output how many dc voltage required?
and what are the changes.
  Reply With Quote
Old 24th February 2011, 03:49 PM   #1330
diyAudio Member
 
apexaudio's Avatar
 
Join Date: Feb 2010
Location: Serbia
Quote:
Originally Posted by yohnsee View Post
Hy! I measured BIAS, it's 30-35mA in cold state for both panels. I will make the other measures as i get home from work. Do i have to measure voltage between power gnd and Z1, Z2, R20, R21?
And one more thing: I didn't connect POWER GND to SIGNAL GND, can it be the problem? But if yes, why has one of the panels 7mV DC offset (i measured it again) and the other 300mV? I can't figure it out.
Any ideas are welcome.
Measure voltage across Z1, Z2, R20, R21. Try to use mached 2N5401/5551 and MJE340/350.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
900W H-class PA Amp with Limiter apexaudio Solid State 3043 Yesterday 08:03 AM
500w power amplifier juneray Solid State 70 16th September 2011 04:05 PM
500W Power Amplifier JRdGreat Solid State 24 16th September 2009 09:48 AM
500W Aleph Amplifier? lscangus Pass Labs 20 19th November 2005 08:29 PM
Looking for 300-500W amplifier audioPT Solid State 3 31st August 2002 12:39 PM


New To Site? Need Help?

All times are GMT. The time now is 08:45 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2