500W PA amplifier with Limiter - Page 104 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th December 2010, 10:11 PM   #1031
diyAudio Member
 
apexaudio's Avatar
 
Join Date: Feb 2010
Location: Serbia
Quote:
Originally Posted by aman khalsa View Post
hello apex sir
pls tell me one thing if in case L.S of my b500 is short circuit what will happen .

is protection work?
With peak current over 8A per output circuit around 2N5401 give AC signal on amp PRO pin, and protect circuit disconnect speaker. Protect will connect speaker after turn amp off and turn on again (power on reset). If you not sure that usen outputs will not break with 8A current don't try to short circuit amp out.
Regards
  Reply With Quote
Old 9th December 2010, 03:36 AM   #1032
diyAudio Member
 
andrewlebon's Avatar
 
Join Date: Feb 2008
hi aman
greetings any more faults on pcb
thanking you
andrewlebon
  Reply With Quote
Old 9th December 2010, 12:06 PM   #1033
triast is offline triast  Indonesia
diyAudio Member
 
Join Date: Aug 2006
Quote:
Originally Posted by apexaudio View Post
APEX B250 after two years in professional use.
Dear Sir apexaudio,

Would you share the pcb, schematic and BOM of B250?

Thx
  Reply With Quote
Old 9th December 2010, 02:04 PM   #1034
diyAudio Member
 
aman khalsa's Avatar
 
Join Date: Oct 2010
Location: punjab
no sir only one mistake ..
  Reply With Quote
Old 9th December 2010, 02:49 PM   #1035
diyAudio Member
 
andrewlebon's Avatar
 
Join Date: Feb 2008
hi aman
greetings tested amp with 4 15 inch speakers 2 ohm load 10 output pairs
supply 70 0 70 dc performed more than i expected tomorrow will test with apex
audio modification triple ef stage and post pictures of set up
THANK YOU APEX AUDIO FOR YOUR CIRCUITS AND HELP have made 4 h class
h900s
1 is it normal when i start amp in series with 100 watt bulb it glows full then i
dissconnect speaker and recconect speaker bulb comes to normal is it ok
thanking you
andrew lebon
  Reply With Quote
Old 9th December 2010, 02:57 PM   #1036
AndrewT is online now AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
The bulb is used to prevent damage when your equipment is wired up wrongly (incorrectly).

Once you have tested the amplifier thoroughly, you must remove the bulb limiter and set up the amplifier to it's quiescent settings. Only after all that is completed should you attach the speakers.
__________________
regards Andrew T.
  Reply With Quote
Old 9th December 2010, 04:16 PM   #1037
diyAudio Member
 
apexaudio's Avatar
 
Join Date: Feb 2010
Location: Serbia
Quote:
Originally Posted by triast View Post
Dear Sir apexaudio,

Would you share the pcb, schematic and BOM of B250?

Thx
Use pcb from B500 for B250 or I can suggest you to build HV350
MOSFET Amplifier IRFP240/IRFP9240
Regards
  Reply With Quote
Old 9th December 2010, 04:21 PM   #1038
diyAudio Member
 
apexaudio's Avatar
 
Join Date: Feb 2010
Location: Serbia
Quote:
Originally Posted by andrewlebon View Post
hi aman
greetings tested amp with 4 15 inch speakers 2 ohm load 10 output pairs
supply 70 0 70 dc performed more than i expected tomorrow will test with apex
audio modification triple ef stage and post pictures of set up
THANK YOU APEX AUDIO FOR YOUR CIRCUITS AND HELP have made 4 h class
h900s
1 is it normal when i start amp in series with 100 watt bulb it glows full then i
dissconnect speaker and recconect speaker bulb comes to normal is it ok
thanking you
andrew lebon
Speakers are not connected when you start amp if you use speaker protect. It's normal when you start amp series bulb will glows at the moment (caps charge).
Regards
  Reply With Quote
Old 9th December 2010, 06:50 PM   #1039
diyAudio Member
 
Join Date: Jul 2008
Quote:
Originally Posted by andrewlebon View Post
hi aman
greetings tested amp with 4 15 inch speakers 2 ohm load 10 output pairs
supply 70 0 70 dc performed more than i expected tomorrow will test with apex
audio modification triple ef stage and post pictures of set up
THANK YOU APEX AUDIO FOR YOUR CIRCUITS AND HELP have made 4 h class
h900s
1 is it normal when i start amp in series with 100 watt bulb it glows full then i
dissconnect speaker and recconect speaker bulb comes to normal is it ok
thanking you
andrew lebon
@ ANDREW

DID YOU USED THE AMAN KHALSA B500 DRIVE UNIT IS THERE ANY PROBLEM WITH THE BOARD? HAVE YOU TRY USING IT PLS ADVICE IM READY TO USED THE BOARD.

THANKS.
  Reply With Quote
Old 10th December 2010, 12:55 AM   #1040
dekes1 is offline dekes1  United States
diyAudio Member
 
Join Date: Dec 2010
New guy here:
I don't have the ability to make my own PCBs. Does anyone have the Gerber and drill diagrams for the B500 (or the B500 with 6 output pairs version) that I could take to a shop that makes boards?

Thank you,
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
900W H-class PA Amp with Limiter apexaudio Solid State 3136 Yesterday 03:47 PM
500w power amplifier juneray Solid State 70 16th September 2011 05:05 PM
500W Power Amplifier JRdGreat Solid State 24 16th September 2009 10:48 AM
500W Aleph Amplifier? lscangus Pass Labs 20 19th November 2005 09:29 PM
Looking for 300-500W amplifier audioPT Solid State 3 31st August 2002 01:39 PM


New To Site? Need Help?

All times are GMT. The time now is 10:55 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2