Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

900W H-class PA Amp with Limiter
900W H-class PA Amp with Limiter
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th September 2012, 07:36 PM   #2251
wattaniya is offline wattaniya
diyAudio Member
 
Join Date: Oct 2009
Quote:
Originally Posted by 44250 View Post
Would you two post the bottom layout,pcb for me? I have this scheme but i donīt have any other files...
HERE IT IS.
Attached Images
File Type: jpg Bottom 265,5 x 57 transistor step.jpg (816.2 KB, 1455 views)
File Type: jpg Apex H Class trans corrected.jpg (109.4 KB, 986 views)
Attached Files
File Type: pdf H900x1IRF2807all.pdf (58.5 KB, 547 views)
File Type: pdf H900x1IRF2807bottom.pdf (30.0 KB, 398 views)
  Reply With Quote
Old 26th September 2012, 08:45 PM   #2252
44250 is offline 44250  Serbia
diyAudio Member
 
44250's Avatar
 
Join Date: Jan 2011
Location: Ugrinovci-Zemun-Belgrade-SERBIA
Send a message via AIM to 44250
Thumbs up GREAT! :)

Quote:
Originally Posted by nazirdigi View Post
HERE IT IS.
Thank You!
  Reply With Quote
Old 27th September 2012, 07:00 AM   #2253
sandeep kayarkar is offline sandeep kayarkar  India
diyAudio Member
 
Join Date: Jun 2011
Location: NAGPUR
Default HAPPY BIRTHDAY

MANY MANY HAPPY RETURNS OF THE DAY SIR MILE
Attached Images
File Type: jpg childs_birthday_cake_recipe3.jpg (25.8 KB, 854 views)
  Reply With Quote
Old 27th September 2012, 11:56 AM   #2254
wattaniya is offline wattaniya
diyAudio Member
 
Join Date: Oct 2009
happy birthday apex sir.
  Reply With Quote
Old 27th September 2012, 12:17 PM   #2255
wiljj78 is offline wiljj78  Philippines
diyAudio Member
 
wiljj78's Avatar
 
Join Date: Mar 2012
Location: Bahrain
Default Happy Birthday!!!

Mr. Mile,

Wishing you all the best and more success....

Happy Birthday!!!!
Attached Images
File Type: jpg 1.jpg (161.6 KB, 790 views)
  Reply With Quote
Old 27th September 2012, 12:36 PM   #2256
Tube Pro is offline Tube Pro  Macao
diyAudio Member
 
Tube Pro's Avatar
 
Join Date: Nov 2009
Location: Macao
Happy Birthday Mile. More power.
  Reply With Quote
Old 27th September 2012, 04:51 PM   #2257
khalsa is offline khalsa  India
diyAudio Member
 
Join Date: Dec 2007
Send a message via Yahoo to khalsa
Happy birthday sir Mile
  Reply With Quote
Old 27th September 2012, 09:24 PM   #2258
crazymechanic is offline crazymechanic  Latvia
diyAudio Member
 
Join Date: Jan 2009
Default h900

Hi , also from me a happy birthday.
My problem is i had much work to do so only now I am back to my project , could someone please tell me what could be the problem when testing the amp with sine waves and watching the output at little input level everything works ok. No distortion no problems, the outcoming signal looks without distortion and so but when turning the input level up to say about 0.6 or higher volts the output transistors stage opens fully up and the transistors are blown but not the fuse which is like originally asked 15A.
I have my ideas what could be wrong maybe you could give me yours?
Thanks.
  Reply With Quote
Old 28th September 2012, 02:36 AM   #2259
iiee3602 is offline iiee3602  Philippines
diyAudio Member
 
Join Date: Jan 2012
Location: Iloilo
Hi, sir mile belated Happy Birthday
  Reply With Quote
Old 28th September 2012, 10:27 AM   #2260
AndrewT is offline AndrewT  Scotland
diyAudio Member
 
Join Date: Jul 2004
Location: Scottish Borders
Quote:
Originally Posted by crazymechanic View Post
................when testing the amp with sine waves and watching the output at little input level everything works ok.................. the outcoming signal looks without distortion and so but when turning the input level up to say about 0.6 or higher volts the output transistors stage opens fully up and the transistors are blown but not the fuse which is like originally asked 15A............
Are you using an oscilloscope to "look" at the output?
How long do you "test" at the higher output levels?
How hot do the output devices get?

Maybe the 15A fuse is too big.

900W into 4r0 is equivalent to 60Vac and 15Aac. The supply rails should be fused at about 7A or 8A. The output rail to the speaker could be fused at 15A.
But those fuses will take seconds to blow, if you overload the amplifier. During those few seconds the output stage and the drivers will have blown. Semiconductors fail a lot faster than fuses !!!!!!!!
__________________
regards Andrew T.
  Reply With Quote

Reply


900W H-class PA Amp with LimiterHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
900w amp module for sale nigelwright7557 Swap Meet 1 15th May 2017 10:36 PM
Nakamichi PA-7 & PA-5 Bias Setting? sourceoneaudio Solid State 6 8th March 2012 01:37 PM
About a very very simple class D PA amp gaetan8888 Class D 8 13th March 2009 03:21 PM
Class-d for a 1kw PA amp MikeHunt79 Class D 4 30th December 2007 07:19 PM
200w Amp + 900w Sub = explosion? 56k Warning Daemonicus Subwoofers 2 31st May 2006 05:30 AM


New To Site? Need Help?

All times are GMT. The time now is 09:42 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki