Armstrong 626 problem - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th February 2010, 06:59 PM   #1
diyAudio Member
 
Join Date: Jul 2009
Default Armstrong 626 problem

Hi,
I bought a faulty Armstrong 626 off ebay that was described as blowing its 2.5amp supply fuse after a few seconds after turn on. When I got I found the supply and decoupling capacitors leaking and swollen so changed them all as well as the main audio ones on the power amp board.

The unit now stays on with a smooth 61volts PSU feed but still no sound on either channel under any selector condition. Does anyone know these recievers well enough to give me a pointer as I am lost with the very complex wiring setup what feeds what!

Regards, Paul
  Reply With Quote
Old 26th February 2011, 11:26 AM   #2
diyAudio Member
 
Join Date: Feb 2011
Location: Cardiff
Hi Paul,

I'm just in the process of giving my Armstrong an overhaul (I've come a cropper with it myself with a burned out resistor on the power board, so maybe not the best person to ask!) but I found this site really useful throughout the overhaul.

The Armstrong 600 Series - Amplifier FAQ and diagrams
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LANCE ARMSTRONG a true sports hero! moe29 The Lounge 172 19th February 2013 02:15 AM
armstrong amplifiers east electronics Solid State 5 4th January 2010 04:45 PM
Armstrong 523 tuner problem stevecole Analogue Source 0 1st December 2009 12:40 PM
Armstrong 521 Amplifier seanww69 Solid State 9 11th July 2007 10:13 PM
Like New Sherwood Newcastle R-626 corryn00 Swap Meet 0 11th June 2004 04:14 AM


New To Site? Need Help?

All times are GMT. The time now is 09:10 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2