Determining causes of distortion - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th February 2010, 09:05 PM   #1
shzmm is offline shzmm  Germany
diyAudio Member
 
Join Date: Jul 2008
Default Determining causes of distortion

Hi and thanks for looking first off.
I am having some difficulties with a solid state Ampeg bass amplifier from the early 90s'. It is a fairly standard 100 watt amplifier with preamplifier and 4 band equalizer.
The problem is that I can't seem to spot the source of an ugly distortion. I can run a sine wave through the amplifier at various frequencies and everything looks quite ok. There was some fluttering on the tops of the waveforms originally so I replaced the main filter caps which seemed to be the ticket. It actually looked good and sounded well. Then, later in the day the distortion came back.
I have checked the signal running a bass instrument through as well but it also looks ok. I should say the distortion is certainly amplitude dependent, but also the more complex waveforms seem to bring the character out. Single notes on the bass aren't distorted unless plucked relatively harder while intervals are immeadiately distorted.
My only guess at this point is one of the coupling capacitors is bad-- they are all of a very cheap ceramic variety. But before I go ahead and change every last one of these is there some test that could more easily show the source of distortions?
Thank you very much for any suggestions.
  Reply With Quote
Old 8th February 2010, 09:19 PM   #2
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
The problem with amplifiers is that they are a loop so its hard to see where the problem starts.

Sounds like a job for a scope and multimeter going thgrough amp a stage at a time and checking for distortion or wrong voltages.

Apply a high level sine wave 2v pk to pk and look for where the distortion starts.
__________________
PCBCAD50 software. http://www.murtonpikesystems.co.uk
  Reply With Quote
Old 9th February 2010, 12:39 AM   #3
wahab is offline wahab  Algeria
diyAudio Member
 
Join Date: Nov 2009
Location: algeria/france
is that one of those transistorized svt using motorola to3 cases?..
it has a tiny u formed heatspreader...
the TO3 cases screws are used as bridges to the supply
rails..if screw has bad contact with a collector,
a part (which one?!!) of the amp will be no more supplied..
anyway, a terrific layout, not counting that the insufficent
heatspreader make a thermal contact switch off easily, cutting
the whole as supply, included the one of the fan !!...
a total failure..i would be ashamed to have designed such
a crappy product...good luck, anyway...
  Reply With Quote
Old 9th February 2010, 12:50 AM   #4
Enzo is offline Enzo  United States
diyAudio Member
 
Join Date: Sep 2004
Location: Lansing, Michigan
I see no mention of trying the amp through a different speaker. Did you?
  Reply With Quote
Old 9th February 2010, 01:58 AM   #5
gootee is offline gootee  United States
diyAudio Member
 
Join Date: Nov 2006
Location: Indiana
Blog Entries: 1
What is the difference in peak input level, between a single note and two notes? Maybe it's just clipping from an input that's too large.

One of the first things I would try would be treating all switch contacts and connectors with Caig De-Oxit, reseating all connectors in the process. They have something for potentiometers, too. See caig.com.

Actually, the very first thing to try is measuring the power supply voltages, and making sure that they are all in spec. If they're not, you have to find and fix whatever is causing that problem, before doing anything else. But note that the problem might not be in the power supply.

The next thing I would look at would be any and all electrolytic capacitors, especially if the unit is more than a few years old. If you have an oscilloscope and a square wave generator (or can cobble one up with a 555 timer IC), you can check the electrolytics' ESRs (Equivalent Series Resistances), probably in-circuit, using the method at TESTING ESR OF ELECTROLYTIC CAPACITORS, without an ESR meter .

I'm not sure why anyone would use ceramic coupling capacitors, and am not sure what their failure mode would be. But maybe you could try putting a good, large-ish film cap in parallel with each one, one at a time, to see if it changes anything.

Good luck.

Tom
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Determining T/S Specs gjeff80 Multi-Way 22 17th October 2004 11:24 PM
Determining The XMAX OMNIFEX Multi-Way 11 8th August 2004 06:29 AM
Determining T/S Specs of a sub nuttinbutSQ Subwoofers 1 29th February 2004 05:00 PM
Help, Determining T/S VAS gjeff80 Multi-Way 10 1st February 2004 08:17 PM
Determining Volume Saydee Multi-Way 11 6th December 2003 09:50 PM


New To Site? Need Help?

All times are GMT. The time now is 02:12 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2