Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th January 2010, 03:19 AM   #1
Simbab is offline Simbab  Canada
diyAudio Member
 
Join Date: Jun 2004
Location: Quebec
Smile Main fuse blow on Classe DR8

Hello
I have an Power Amplifier Classe DR-8.
The main fuse burns (5A slow blow).
Once, i active the switch to the front of the amp, the fuse burns instantly.
A second try with a new fuse and I hear the relay activates after 8 seconds.
Do you have a suggestion for this problem

Thank you and good day

Yves
  Reply With Quote
Old 21st August 2010, 09:44 PM   #2
Simbab is offline Simbab  Canada
diyAudio Member
 
Join Date: Jun 2004
Location: Quebec
For 100V-120V 5A slo-blo
For 220V-240V 4A slo-blo
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New 'lytics blow the fuse glorocks Parts 13 4th June 2009 02:54 AM
Sa-5.1 blow fuse jpweaner2 Tubes / Valves 0 3rd May 2007 01:36 PM
Why main fuse and not rail fuse? digital desire Solid State 10 3rd December 2006 08:07 PM
Fried a slow blow 4 A fuse chris ma Everything Else 2 10th October 2003 06:59 AM
Tube amp fuse blow out Gabevee Tubes / Valves 1 4th March 2002 03:55 PM


New To Site? Need Help?

All times are GMT. The time now is 05:05 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2