Power Acoustik ps4-600 dead - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th December 2009, 02:45 AM   #1
diyAudio Member
 
Join Date: Jun 2002
Location: non
Default Power Acoustik ps4-600 dead

Ran into one of these to repair. it is totally dead. no action from the SMPS. Cannot find a schematic or data on this amp. So i am looking for anyone that is experienced in this particular amplifier.

I checked all power and output transistors plus various other components and everything appears to be fine. even replaced the TL494 with a known-good one. dead....

I noticed that TL494 Error amplifier 2 is positive-going true output. thus inhibiting the SMPS from running. negative input i think is pin 15, is a rock 5V from the reference generator. then the positive input pin 16, is sitting around 9V. this causing the output to be 1 from the comparator, and inhibiting operation. I have traced that whole circuit and i am comming up with nothing. If i cross-out pins 15-16 this disabling the comparator, the SMPS will power up, power LED green and no protect LED kicking in either. havent tested for sound, as i didnt want to use it for long with a disabled error amplifier circuit. I guess the error amplifier is used for self-regulation, but im not sure, however that circuit appears to be malfunctioning.

any ideas?

Last edited by mbates14; 29th December 2009 at 02:47 AM.
  Reply With Quote
Old 29th December 2009, 03:01 AM   #2
mavric is offline mavric  United States
diyAudio Member
 
mavric's Avatar
 
Join Date: Nov 2009
Location: some place nice
Honestly, you can get a new one for 60usd. It is a junk amp, over rated and under powered, this is probaly why you cannot fix it. Power Accoustic tends to use cheap parts but the same chassis for their amps. I would just get another 4 channel with a warranty, not domething someone put together just to make sound. just my opinion, Mavric
  Reply With Quote
Old 29th December 2009, 03:05 AM   #3
diyAudio Member
 
Join Date: Jun 2002
Location: non
oh, ill repair it. watch me..... hey however thanks for your opinion anyway...
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Acoustik Amp Help 22chet Car Audio 7 22nd February 2009 10:05 AM
Power Acoustik Amp chadrock Car Audio 28 19th March 2008 05:37 AM
Power Acoustik A2400db spooney Car Audio 21 19th March 2008 12:05 AM
Help - JansZen Z-600 - dead step-up transformer? centaurus3200 Planars & Exotics 2 5th May 2006 06:35 PM


New To Site? Need Help?

All times are GMT. The time now is 06:41 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2