Boss Riot R735 in protection mode - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th November 2009, 03:18 PM   #1
diyAudio Member
 
Join Date: Nov 2009
Default Boss Riot R735 in protection mode

I had this Boss Riot R735 working for a couple years and yesterday it was working for 1 hour in a row and stopped working. It went into Protection Mode (Red LED). Every 10-15 seconds it tries to work, the Green LED turns on for a fraction of seconds and returns to Protection mode. What could have burnt, a transistor, a relay, what? any help will be appreciated. Here are the spects and picture of this amp:

Boss Riot R735 amplifier:

Tri-mode operation
Max Power 2 Ohm 250 Watts X 4
RMS Power 4 Ohm 100 Watts X 4
Bridged Power 500 Watts X 2
Signal-To-Noise Ratio: >105dB
THD: 0.01%
Variable high &low pass crossovers
Remote subwoofer level control
High pass crossovers
Line and speaker level inputs
0-+18dB Bass Boost
Line outputs
Gain control
Power and Protection LEDs
MOSFET power supply
Plexiglass top cover
Input voltage switch 100mV-2V/2V-8V
11 3/4" W x 2 3/16"H x 11" L
1-year SonicElectronix.com warranty
Attached Images
File Type: jpg r735.jpg (23.0 KB, 15 views)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nad 304 Protection Mode sirhenry Solid State 2 14th May 2009 09:46 AM
amp protection mode ? chrissy14xsi Car Audio 40 14th March 2009 02:00 AM
Amp Protection Mode sseabrook07 Car Audio 3 29th October 2006 02:26 PM
protection mode won't go off Darkcrusher Solid State 5 2nd February 2006 02:10 PM
Help! Audiobahn A12001D always goes into Protection mode! OxygenGVX Car Audio 5 9th March 2004 07:39 PM


New To Site? Need Help?

All times are GMT. The time now is 11:55 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2