Roland SPA-240 amplifier - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th November 2009, 11:59 AM   #1
molesz is offline molesz  Hungary
diyAudio Member
 
Join Date: Nov 2009
Unhappy Roland SPA-240 amplifier

I have managed to salvage one long time burned down Roland SPA-240 power aplifier. It is in my family since who-knows-when (early 80's), and it is pretty much damaged and I would like to restore it to its original look and sound, but I would need a service manual or at least the schematic for it.
A fairly good scan will do.

Anybody .... HELP!

Thank You in advance
  Reply With Quote
Old 26th November 2009, 09:58 AM   #2
molesz is offline molesz  Hungary
diyAudio Member
 
Join Date: Nov 2009
Never mind, I found the service manual and the schematics for Roland SPA-240. So if someone have a problem with this beast, just call :-)

Thanks anyway.
  Reply With Quote
Old 2nd January 2014, 09:16 AM   #3
diyAudio Member
 
Join Date: Sep 2006
There is two for sale locally(or at least in my country) both with an error in the input stage, as spesified by the seller. What common faults can I expect to find? I hope to buy these and pair one up with some rather unusual Shure SR112/116B monitors.

If you have the manual, I would appreciate a copy.
  Reply With Quote
Old 3rd January 2014, 06:27 AM   #4
molesz is offline molesz  Hungary
diyAudio Member
 
Join Date: Nov 2009
Hi, can't really talk about common problems with these amplifiers because they are really rare. Mine had a burned down output stage with out of production Toshiba transistors which I had replaced with Sankens. Also did some upgrades to other components to improve the sound and indeed now it is a power amplifier with fabulous sound. It kicked out 3 fine Marantz amps which I used to listen to (they are collecting dust since)!
Those You have found might just have minor problems which can occur due to the age of the components. Even it can be a matter of cleaning connections, resoldering, a few part change and readjustments.
As soon as I dig out the manual from my archive I will send it to You.

Best regards
  Reply With Quote
Old 3rd January 2014, 06:50 AM   #5
molesz is offline molesz  Hungary
diyAudio Member
 
Join Date: Nov 2009
Here is the link for the file.

https://dl.dropboxusercontent.com/u/...0documents.zip

Best wishes
  Reply With Quote
Old 3rd January 2014, 10:29 AM   #6
molesz is offline molesz  Hungary
diyAudio Member
 
Join Date: Nov 2009
Just pay attention to the serial number remark in the schematcs, there are some differences in different editions of the amp but once You have the board in hand You will notice them. The original output tranzistors are Toshiba and they are out of production for a while but the amp got a fairly fast protection so I could not imagine what made my crash and burn. Roland has no forced cooling and they get warm if driven hard. Just let them have all the vents free for a natural airflow and there will be no problem. Actually they have a fantastic sound when the working temp is reached. The input limiter pots are best kept on max, I did not took them out just to keep the originality of the amp.
Um, I can't remember all the details of the restoration but if You have any problems I would help gladly.

Best regards
  Reply With Quote
Old 7th January 2014, 07:22 AM   #7
diyAudio Member
 
Join Date: Sep 2006
Hi, didnt check for a reply here. The file on dropbox are not available. Guess its time limited?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for Roland KC-550 sechmatics ATech Solid State 1 19th May 2012 05:42 AM
Trouble with roland ac-60! teleman Analog Line Level 5 1st November 2009 05:14 PM
Schematic for Roland PM-30 BrianDonegan Instruments and Amps 0 17th July 2008 07:50 PM
WTB: Roland M1000 tf1216 Swap Meet 0 30th November 2005 12:21 PM
mod for roland 405 amp DanTheBluesMan Solid State 1 10th September 2002 06:39 AM


New To Site? Need Help?

All times are GMT. The time now is 02:45 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2