Channel Balance question?? - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 14th November 2009, 03:37 PM   #1
Ograv is offline Ograv  United States
diyAudio Member
 
Join Date: Mar 2008
Location: Dexter MI
Default Channel Balance question??

So I buy a vintage Rotel receiver. I hook it up & seem to notice a channel imbalance issue. It seems like the left channel is slightly lower in volume, when listening to it in a near field situation. Far field (>7 feet) it sounds OK, but I still seem to think the left is slightly lower. So I investigate & find that the left channel speaker output is ~15% lower than the right & correctable with the balance pot. I work backward & discover the output from the preamp is 15% lower So the "issue" is in the preamp. I check the HFE all all transistors & all match pretty good, caps check good, check many resistors & those are good. Can't find a problem. Check the volume & balance pots & see some variation there. So for reference, I check 2 other receivers I have (Tandberg & another Rotel) and I find the same thing. Below 10WPC, the right channel is stronger than the left by 10-20% WPC. Is this typical? Anyone else experience this. OK the sample size is not large, but it is bigger than a mass sample of one. Hard to believe that all 3 receivers would exhibit the same channel being "significantly" higher than the other. I tested the channels with a load & without (AC voltage at the speaker terminals) and measured the output voltage with a Fluke 189 & wattage with a Sencore Stereo Tester so I know the measurements are accurate & correlated. Thanx in advance for any responses. - Bob V
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Guitar amp channel question Trepan Instruments and Amps 3 22nd May 2007 03:46 PM
One more question about P37 and balance control roger-k Solid State 1 8th October 2006 05:08 PM
6 channel LM4780 question Wynand Chip Amps 18 24th November 2005 01:58 PM
Center channel question txtubenoob Multi-Way 2 14th October 2005 03:23 PM
6-channel balance and fader Fragen Parts 0 23rd November 2004 02:25 PM


New To Site? Need Help?

All times are GMT. The time now is 09:10 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2