Denon PMA-680R Burnt - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th May 2003, 08:20 AM   #1
Gunkal is offline Gunkal  Sweden
diyAudio Member
 
Join Date: May 2003
Location: Falkenberg
Default Denon PMA-680R Burnt

The resistors R501 and R502 were burnt and the B1274 was shorted. I changed the parts but when I turned the power on the resistors "lit up" again. Does anyone have any suggestions what other components could be faulty. Does anyone have a schematic for the amp ? I would appreciate any help, thanks in advance.

Gunkal
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! tube amp burnt? flatsound Tubes / Valves 9 26th June 2009 02:41 AM
IRFP064 gets burnt xyz9915 Power Supplies 30 5th February 2009 02:57 AM
Need Help - Burnt Sanken p.heimpold Solid State 16 30th May 2007 05:05 PM
Sub burnt bad. Garbage? Miedosoracing Subwoofers 4 27th April 2006 01:59 PM
burnt transformer A'af Digital Source 1 20th May 2005 11:23 PM


New To Site? Need Help?

All times are GMT. The time now is 07:08 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2