diyAudio

diyAudio (http://www.diyaudio.com/forums/)
-   Solid State (http://www.diyaudio.com/forums/solid-state/)
-   -   HEXFET amp in Elektor (http://www.diyaudio.com/forums/solid-state/15238-hexfet-amp-elektor.html)

Taliesin 16th May 2003 02:37 PM

HEXFET amp in Elektor
 
Elektor published an article in September 1995 issue describing a 100W hexfet amplifier, using IGBT devices.

I ordered a couple of boards and built this amp up. On switch on it goes straight into runaway, and burns out the + rail IGBT devices in short order. Running the board with a current limited supply so that nothing heats up, and I have a big DC offset on the speaker output - in the region of several volts.

Tie the "base" of the power IGBT's to its respective supply rail to force it off, and I cannot find a fault in the circuit. Nothing gets hot, and voltages at various points of the circuit make sense, so the problem seems to only appear when the power circuit feed back circuit is active.

I've had two different electronic engineer friends try and diagnose the board, with no success, although neither of them have much experience with amps.

I guess my question really is has anyone else ever built up this circuit and did they struggle to get it stable?

Ian

paulb 16th May 2003 06:58 PM

Maybe you could try tracking down the author.

audioPT 16th May 2003 07:23 PM

Is this one??

http://steve.sky.net.ua/Audio/semi/IGBT/IGBT1.jpg

It works very fine...

Have you checked if the IGBT's are counterfeit like some toshiba transistors??

Regards..

Pedro Martins

Taliesin 19th May 2003 06:34 AM

Yes, that's the one.

I thought about the counterfeit thing. I bought the devices from the official local importer for the chips.

I've also tested the chips out of crcuit and they behave according to the datasheet, although I haven't tested them in any sort of AC circuit.

I know it's most likely something I've done wrong, but 3 different people so far haven't been able to find a problem with my assembly. Also, I've built up two complete boards and they both exhibit exactly the same behaviour.

Ian

jackinnj 19th May 2003 04:42 PM

don't know what the output stage looks like
 
assuming that there aren't any cold connections on the board, you might want to take a 10 ohm, 2 watt resistor, wind 7 turns of (insulated #18 magnet wire) wire around it and connect in the line from the PA to the speaker and see if this stops the oscillation which is driving the amp into excessive consumption (consuming itself). <p>Perhaps first try driving a completely resistive load...

Taliesin 20th May 2003 12:00 PM

I haven't even tried connecting it to a speaker yet. For one thing the DC offset is such that I would risk frying the speaker.

The thing starts to self destruct as soon as power is applied, with neither input or speaker connected to anything.

Ian

hugonot 20th May 2003 12:48 PM

Problem
 
At first, go to electronic shop and buy a pack of cheap power Mosfests, as I know igbt are GT20D101/201 5$ per piece. Mosfets needs greater Gate to Source voltage 3-4 volts vs 2-3 igbt. You have to pick a zener diode 5.1V or even smaller parallel to G-S of Mosfet. You have to check a dc servo ( if it is there ). If problem occur with Mosfets, check a driver stage ( MJE15030/15031 if I'm right ), voltage across emitter resistor are proportional to bias voltage Vb/Ve = Rc/Re. And check voltage of Vbe multipler ( potentiometr must be put at minimum at first power on ). If you could send a circuit diagram then it could be easier to say something about problem.

Taliesin 21st May 2003 08:24 AM

Thanks for that advice ... it's really helpful. Being able to work with some MOSFET's instead of the IGBT's would be helpful, and hopefully cheaper!

I'll scan in the schematic and post it sometime today.

Ian

Taliesin 21st May 2003 11:44 AM

I can't make the schematic fit within the site limitations of 800x600. :mad:

If you give me an email address I can email it to you.

Ian

hugonot 21st May 2003 12:13 PM

e-mail
 
ok. chwila_ciszy@go2.pl


All times are GMT. The time now is 07:28 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio


Content Relevant URLs by vBSEO 3.3.2