Denon AVR 1802 no function - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 12th September 2009, 06:25 PM   #1
kap is offline kap
diyAudio Member
 
Join Date: Sep 2009
Default Denon AVR 1802 no function

Hi,

Recently I got hands on a broken Denon AVR 1802. Both transformers are working and the transistors look in good shape. But I dont get ant indication of functioning. The main-transformer on relay doesn't close. So I bypassed it and the most I could get is all the LEDs on front panel on (no blinking).

Anyone got any ideas what could be wrong here? (I checked the relay and its working fine)

best

PS: I unasselbled the unit and am only working with the main PCB, is that enough to check functionality?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Function Generator? TheDriver Parts 4 18th August 2008 10:46 AM
Amp Will Not Function prorms Solid State 16 2nd December 2006 09:26 PM
Transfer Function jclouse Multi-Way 22 1st July 2006 02:19 PM
What's the function of this? stef1777 Analog Line Level 5 21st March 2006 12:16 PM
Why this amp does not function ????? PicancoNet Solid State 10 23rd January 2004 05:45 PM


New To Site? Need Help?

All times are GMT. The time now is 03:12 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2