DIY Curve Tracer for PC - Page 30 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th December 2012, 04:37 PM   #291
CeeVee is offline CeeVee  Portugal
diyAudio Member
 
CeeVee's Avatar
 
Join Date: Dec 2006
Solved,

Q3 you had fitted was defective ( Tip132 ) i replaced with TIP142 and replaced Q4 for good measure with TIP 147

My only problem now is that i need a PSU that lets me measure up to 2500mA , this one will only let me go up to 2000mA without cutting off.

Even so you can see 2 traces that exceeded current capacity and droped Id to 0 !

Thanks for the tip.
Here is a picture and cuv file of measurements now. ( 2SJ201 and 2SK1530 ).
Attached Images
File Type: jpg Audiophonics and Zhou.jpg (369.7 KB, 236 views)
Attached Files
File Type: zip Audiophonics and Zhou.zip (19.0 KB, 20 views)
  Reply With Quote
Old 29th December 2012, 12:29 AM   #292
locky_z is offline locky_z  China
diyAudio Member
 
Join Date: Jun 2004
Location: XH
The protect circuit as below
Click the image to open in full size.
when protect active,the C/E channel amp power supply will lost, then system will stop measure.


The R48, R50 and the Rds of PMOS and the 'red line' and the zener D2((the zener on pcb may be 6~9V) control the current protect.

If you want more current, you can do:
1. Use less Rds of PMOS
2. Increase the R48
3. Decrease the R50
4. Use high voltage zener diode replace D2.but no more than 20V.
5. Install the 'Protect SW' button(near the 'Over-current' Indicator LED),If you want more current,hold down the 'Protect SW' button, then the protect will fail.


If you want less current,you can do:
1.use more Rds of PMOS
2.decrease the R48
3.Increase the R50
4.cut off the red-line and replace with a resistor.
  Reply With Quote
Old 29th December 2012, 01:11 AM   #293
CeeVee is offline CeeVee  Portugal
diyAudio Member
 
CeeVee's Avatar
 
Join Date: Dec 2006
Locky_z...image not visible
  Reply With Quote
Old 29th December 2012, 01:46 AM   #294
locky_z is offline locky_z  China
diyAudio Member
 
Join Date: Jun 2004
Location: XH
Click the image to open in full size.
Attached Images
File Type: png protect.PNG (78.8 KB, 827 views)
  Reply With Quote
Old 29th December 2012, 05:22 AM   #295
diyAudio Member
 
Join Date: Jul 2002
Location: ISRAEL
Default Unable to load P Conditions

This happened just now for PNP conditions, as i was running tests the Go button remains gray and unoperational.
The NPN conditions are loading properly and seems to function too.
Please see picture..
What do you think can be the cause of this??
Thanks...
Attached Images
File Type: gif Curve tracer1.gif (23.4 KB, 56 views)

Last edited by BenY; 29th December 2012 at 05:29 AM.
  Reply With Quote
Old 29th December 2012, 09:23 AM   #296
locky_z is offline locky_z  China
diyAudio Member
 
Join Date: Jun 2004
Location: XH
Quote:
Originally Posted by BenY View Post
This happened just now for PNP conditions, as i was running tests the Go button remains gray and unoperational.
The NPN conditions are loading properly and seems to function too.
Please see picture..
What do you think can be the cause of this??
Thanks...
The device is online?
The program title will be pointed out that the device is online.
If not online then goto Options->Config, click 'Auto detect and get parameter' button.

If device online and the 'Curve type' had defined,the the 'Go' button will enable.


How your error window appear?
  Reply With Quote
Old 29th December 2012, 11:11 AM   #297
diyAudio Member
 
Join Date: Jul 2002
Location: ISRAEL
Yes the device is online..
I suspected a program file may have corrupted so a ran a backup that i kept on a portable disk and this copy runs fine.
I tried to copy the good backup to the "Program Files" folder over the problematic copy but it still showing that issue.
Please note that this malfunction is showing only when i try to load conditions for P Hfe-Ic=% and nothing else.
But when i run the backup everything run good..
I will investigate further, but wonder what memory store other then .ini file is kpet for preferences ??...
  Reply With Quote
Old 29th December 2012, 01:06 PM   #298
locky_z is offline locky_z  China
diyAudio Member
 
Join Date: Jun 2004
Location: XH
May be something wrong in the 'ads7871_vs3.pre' file
The file 'ads7871_v3s.pre' is store the pre-define measure conditions.

Try to overwrite the ads7871_v3s.pre file with your backup.
  Reply With Quote
Old 29th December 2012, 03:44 PM   #299
diyAudio Member
 
Join Date: Jul 2002
Location: ISRAEL
Yes.. I tried overwriting the whole program folder and it`s still the same.
The issue is only with P hfe-Ic-% and nothing else, Should I erase that parameter and rebild it again?? Where and how do i delete it ??
Does it make any sense to approch the problem this way??
Many thanks..
  Reply With Quote
Old 29th December 2012, 04:07 PM   #300
diyAudio Member
 
Join Date: Jul 2002
Location: ISRAEL
Problem solved.
Found an error in .PRE file
I thought it was an old .ini file i renamed .pre and ignored it for that reason.
Sorry for the trouble & thank you.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using The Tektronix 575 Curve Tracer Mark A. Gulbrandsen Solid State 29 21st May 2012 08:01 PM
B-H Curve Tracer gpapag Equipment & Tools 9 16th January 2011 09:22 PM
curve tracer? maxpou Solid State 4 24th October 2009 06:29 PM
Virtual Tek 576/577 curve tracer in EWB V10 jackinnj Equipment & Tools 0 1st March 2007 02:41 PM
FS: tektronix 575 curve tracer SQ Kid Swap Meet 3 11th July 2004 05:22 PM


New To Site? Need Help?

All times are GMT. The time now is 09:32 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2