Problem after recapping Meiridian PSU PCB - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th September 2009, 02:30 PM   #1
hew128 is offline hew128  Singapore
diyAudio Member
 
Join Date: Jan 2006
Location: Singapore
Default Problem after recapping Meiridian PSU PCB

Hi everyone,

My Meridian DAC no longer works after I recap the electrolytics on the PSU motherboard.

It powers-up and looks like it does detect the digital signal but no sound. Also the TOS links does not light up.

The PCB looks like a multi-layer. Not sure if that is the reason why the replacement caused problems?

Thank you for any advise in the matter!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Recapping PS in a Hafler DH-101 gil1 Solid State 26 30th May 2012 08:45 PM
recapping Threshold SL-10 vendo81 Pass Labs 4 3rd November 2010 02:26 AM
recapping peace brainerd Everything Else 3 20th February 2006 07:26 PM
Recapping optimization? kyrochan Solid State 0 26th October 2005 03:16 PM
Recapping questions MikeA57 Solid State 1 24th March 2005 08:57 PM


New To Site? Need Help?

All times are GMT. The time now is 10:29 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2