NAD 3150 repair - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 31st August 2009, 06:26 PM   #1
diyAudio Member
 
Join Date: Nov 2008
Default NAD 3150 repair

So, I had a NAD 3150.. unfortunately, I've never built a solid state, nor do I have the service manuals..

The problem: no sound in speakers / no speaker output in A or B

So far, I know its not the input, there is signal coming out of the rec out and the preout. If i put a line level into the "main in" where the preout is jumpered to, there is still no sound to the speakers. Can anyone advise on where to begin?

thanks!
  Reply With Quote
Old 1st September 2009, 03:48 AM   #2
Bigred is offline Bigred  Canada
diyAudio Member
 
Join Date: Jul 2007
Well you have done some good basic troubleshooting thus far eliminating the preamp side of things. Is everything else with the amp normal such as passing protection with the speaker relay engaging?
  Reply With Quote
Old 1st September 2009, 05:33 AM   #3
diyAudio Member
 
Join Date: Nov 2008
I'm not sure I understand what you mean.. the "protection" light on the panel is on..
  Reply With Quote
Old 1st September 2009, 03:38 PM   #4
Bigred is offline Bigred  Canada
diyAudio Member
 
Join Date: Jul 2007
The light on means its in "protection" and the speaker relay will not engage. When the amp is not going in to protection, the light is off and you should be able to hear a distinct "click" of the relay engaging after a few seconds or so after powering on. There is a fault in the amp section or the protection circuit itself.

I surmize that you have no experience with electronics and amp repair. I'm not a proponent of getting people with little to no experience poking around in an amplifier. My best advice at this point would be to have an experienced tech check the amp out for you.
  Reply With Quote
Old 1st September 2009, 04:07 PM   #5
diyAudio Member
 
Join Date: Nov 2008
If you can point me in the right direction I think I can handle it. I've built a simple se and various other electronics.. its just my first solid state experience. =)and yes, you're right, I don't hear the click... should've thought of that first. sounds like something is shorting?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NAD 2150/3150 Schematic + advice steve_aus Solid State 1 22nd November 2011 06:15 PM
NAD 3150 Amp Channel Dropout eyendall Solid State 5 17th November 2007 11:16 PM
Schematic/Service Manual NAD 3150 corrieb Solid State 2 6th February 2007 01:36 AM
Volume/balance pot for NAD 3150 amp johngalt47 Swap Meet 0 6th November 2004 09:22 PM


New To Site? Need Help?

All times are GMT. The time now is 12:08 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2