LEAK stereo 70 cutting out - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th August 2009, 03:00 AM   #1
diyAudio Member
 
Join Date: Mar 2009
Default LEAK stereo 70 cutting out

I have a Leak stereo 70 which cuts out on the left chanel between 12 oclock and 1 oclock. If I reduce the volume a fraction, or increase it a fraction it is fine, it cuts out on the left chanel only, it just goes dead. When turning the volume up and down quickly there is a faint crackling on the left chanel when its dead, otherwise it sounds superb. I have my cd player running through the tape monitor switch to take the tone controls out of the loop too. Any ideas ?
  Reply With Quote
Old 24th August 2009, 03:06 AM   #2
diyAudio Member
 
Jan Dupont's Avatar
 
Join Date: Apr 2003
Location: Copenhagen, Denmark
Send a message via MSN to Jan Dupont
Change your Volume potentiometer
__________________
Free Schematic and Service Manual downloads www.audio-circuit.dk, Company: www.dupont-audio.com, Joint venture: www.DupontMantra.com
  Reply With Quote
Old 24th August 2009, 03:33 AM   #3
diyAudio Member
 
Join Date: Mar 2005
Location: California
or clean it
  Reply With Quote
Old 24th August 2009, 01:34 PM   #4
diyAudio Member
 
Join Date: Mar 2009
Default Leak stereo 70

Thanks for the replies, Is it easy to clean the potentioneter, im imagining that it is some kind of circular track on the Leak 70 with fingers that run across it, would that be correct ?
  Reply With Quote
Old 24th August 2009, 02:09 PM   #5
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
Quote:
Originally Posted by Minimuslover7 View Post
Thanks for the replies, Is it easy to clean the potentioneter, im imagining that it is some kind of circular track on the Leak 70 with fingers that run across it, would that be correct ?
I never clean pots or switches as they are probably old anyway.
I tend to replace them as they quickly become faulty again if cleaned.
__________________
PCBCAD50 software. http://www.murtonpikesystems.co.uk
  Reply With Quote
Old 24th August 2009, 02:47 PM   #6
diyAudio Member
 
Jan Dupont's Avatar
 
Join Date: Apr 2003
Location: Copenhagen, Denmark
Send a message via MSN to Jan Dupont
If the pot is an open type, try spray WD40 into the pot.
And before everbody starts at me, this was a trick I got from Rob Flain at QUAD Audio.
Used it on my old QUAD 34 pre 7 years ago, and there has never been a problem since (seems almost as a one time cure)
__________________
Free Schematic and Service Manual downloads www.audio-circuit.dk, Company: www.dupont-audio.com, Joint venture: www.DupontMantra.com
  Reply With Quote
Old 24th August 2009, 02:59 PM   #7
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
Quote:
Originally Posted by Jan Dupont View Post
If the pot is an open type, try spray WD40 into the pot.
And before everbody starts at me, this was a trick I got from Rob Flain at QUAD Audio.
Used it on my old QUAD 34 pre 7 years ago, and there has never been a problem since (seems almost as a one time cure)
It depends on why the pot has gone faulty.
If the pot track is simply worn out then no amount of WD40 will fix it, it needs replacing.

If some dust or hair has got under the wiper then WD40 will probably blow it out.
__________________
PCBCAD50 software. http://www.murtonpikesystems.co.uk
  Reply With Quote
Old 24th August 2009, 03:03 PM   #8
diyAudio Member
 
Jan Dupont's Avatar
 
Join Date: Apr 2003
Location: Copenhagen, Denmark
Send a message via MSN to Jan Dupont
Quote:
Originally Posted by nigelwright7557 View Post
It depends on why the pot has gone faulty.
If the pot track is simply worn out then no amount of WD40 will fix it, it needs replacing.
Yes of course
__________________
Free Schematic and Service Manual downloads www.audio-circuit.dk, Company: www.dupont-audio.com, Joint venture: www.DupontMantra.com
  Reply With Quote
Old 24th August 2009, 03:23 PM   #9
diyAudio Member
 
Join Date: Jul 2005
Location: North Derbyshire
Quote:
Originally Posted by Jan Dupont View Post
If the pot is an open type, try spray WD40 into the pot.
And before everbody starts at me, this was a trick I got from Rob Flain at QUAD Audio.
I've been using WD40 professionally for decades now, it's FAR better than so called 'switch cleaners', particularly on pots.

It's very rare for a pot to be worn out, and a quick squirt of WD almost always provides a long lasting cure.

I had a Leak Stereo 70 for years, great amps - I only replaced it because I bought a three head cassette deck and it didn't work very well with it. Over the many years I had it, the Leak got used for disco's, guitar's, all sorts of things
__________________
Nigel Goodwin
  Reply With Quote
Old 24th August 2009, 03:32 PM   #10
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
Quote:
Originally Posted by Nigel Goodwin View Post
I've been using WD40 professionally for decades now, it's FAR better than so called 'switch cleaners', particularly on pots.

It's very rare for a pot to be worn out, and a quick squirt of WD almost always provides a long lasting cure.

I had a Leak Stereo 70 for years, great amps - I only replaced it because I bought a three head cassette deck and it didn't work very well with it. Over the many years I had it, the Leak got used for disco's, guitar's, all sorts of things
For home use pots usually last the life of the equipment as they are rarely tweaked.

I run a mobile disco and the crossfader is being used for hours on end.
This means they dont last long. This is why they are usually a module that be easily be replaced.
__________________
PCBCAD50 software. http://www.murtonpikesystems.co.uk
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xindak attenuation for use with Leak Stereo 20, help please camperman Tubes / Valves 15 20th May 2008 07:12 PM
Leak Stereo 20 clone? possibly with 6V6? bikehorn Tubes / Valves 26 29th March 2007 01:52 AM
Leak stereo 70 fault harrygrey382 Solid State 16 25th February 2007 04:07 PM
Leak Stereo 20 questions Johan Potgieter Tubes / Valves 23 30th April 2006 11:57 PM
Mods on leak stereo 20 bronto64 Tubes / Valves 22 26th April 2004 08:27 PM


New To Site? Need Help?

All times are GMT. The time now is 03:09 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2