Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th July 2009, 02:51 PM   #1
diyAudio Member
 
Join Date: Jul 2009
Default old kay bass amp volume problem

Hello, I am being sent an old Kay Bass and organ head. The owner told me that the amp works yet sounds very faint. Does anyone have an idea what could be wrong? I dont know the model number but it sounds like an easy fix, any ideas anyone?
  Reply With Quote
Old 30th July 2009, 12:53 AM   #2
Enzo is offline Enzo  United States
diyAudio Member
 
Join Date: Sep 2004
Location: Lansing, Michigan
Could be simple, or could need a cap job. I'd start by looking for DC leakage through the various coupling caps.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Volume swinging problem graeme uk Tubes / Valves 14 7th December 2008 01:47 PM
Amp volume knob problem Jabroni Solid State 4 9th December 2004 08:17 AM
Volume knob problem plz help silentblackhat Solid State 1 28th July 2004 04:19 PM
Bass volume control... eRiCdWoNg Parts 0 18th May 2004 06:24 PM
Volume problem... Amphersands Solid State 6 22nd January 2004 04:35 PM


New To Site? Need Help?

All times are GMT. The time now is 08:48 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2