HELP Trio L07M11 - Page 3 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 11th June 2009, 03:19 PM   #21
diyAudio Member
 
Moondog55's Avatar
 
Join Date: Jun 2007
Location: Norlane; Geelong: Victoria: Australia
Just read through the thread.
Good info, I'll put my two working marks aside until I can get some help with a rescue effort
__________________
QUOTE" The more I know, the more I know, I know (insert maniacal laugh >here<) NOTHING"
  Reply With Quote
Old 14th June 2009, 02:38 AM   #22
diyAudio Member
 
Moondog55's Avatar
 
Join Date: Jun 2007
Location: Norlane; Geelong: Victoria: Australia
Thanx for all your help on this one.

Is there any-one closer than Queensland willing to lend a hand in a full restoration of these classic amps???

Not asking for charity here, I'm trying to learn but want a teacher and I can scrape together some money for good parts.

I guess that the aging components could be improved on, but I have been warned that due to the inherent complexity of these amps not to attempt a repair as a first project.

I can swap or pay cash to who-ever can help, but i would like to keep these classics going.

I have sent an email to Restorer John thru Audio Karma but haven't yet received a reply ( it may even be John who sold them to me thru E*** )

Regards
Ted
__________________
QUOTE" The more I know, the more I know, I know (insert maniacal laugh >here<) NOTHING"
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
trio W-38 problems damianl Tubes / Valves 11 11th December 2010 10:59 PM
Trio TA-80W radioeng Chip Amps 2 4th May 2009 12:11 AM
Trio W-45a Amp- namatjira Tubes / Valves 1 12th April 2008 05:14 AM
Trio (kenwood) LS-77 PTSOUNDLAB Multi-Way 5 7th April 2006 10:04 PM
trio amp latala Solid State 1 24th February 2006 09:09 PM


New To Site? Need Help?

All times are GMT. The time now is 07:10 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2