AB Amp keep blowing fuse - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th May 2009, 11:02 PM   #1
diyAudio Member
 
Join Date: May 2009
Default AB Amp keep blowing fuse

I have an AB amplifier that keep blowing fuses.
Iam using the correct fuse.
It will power up then slowly the power light goes out after few second.
Thanks for some help.

Karl
  Reply With Quote
Old 28th May 2009, 11:24 PM   #2
diyAudio Member
 
Join Date: Oct 2007
Hi! Can you post the schematic, or its link? There's got to be a trimpot to set the quiescent current, take a look at it to know if it's all the way to right or left... probably quiescent current is too high, and be careful, if the trimpot is set at max quiescent current, the output trannies will reach the Hades in less than two
seconds...
  Reply With Quote
Old 28th May 2009, 11:36 PM   #3
Arcaman is offline Arcaman  Italy
diyAudio Member
 
Join Date: Mar 2009
Does it without any load connected ?
Have you checked if the voltage selector is in the right position, if present?
  Reply With Quote
Old 29th May 2009, 02:19 AM   #4
diyAudio Member
 
nigelwright7557's Avatar
 
Join Date: Apr 2008
Location: Carlisle, England
If you havent adjusted the presets then its probably the output transistors gone.
Anything else usually doesnt take enough current to blow the fuses although a shorted capacitor might.
__________________
PCBCAD50 software. http://www.murtonpikesystems.co.uk
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why does fuse keep blowing imhondamatt Car Audio 26 19th April 2009 08:14 AM
Fuse housing melting but fuse not blowing, ppi amp rawadia Car Audio 21 2nd August 2008 11:39 AM
Blowing my fuse (s) Jimlondon Chip Amps 7 7th March 2005 07:03 PM
Fuse keeps blowing Vivek Everything Else 4 1st August 2003 07:31 AM


New To Site? Need Help?

All times are GMT. The time now is 06:49 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2