Problem with Rotel RB-985 MKII 5 channel home cinema amplifier... - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th April 2009, 08:54 AM   #1
hoppaz is offline hoppaz  United Kingdom
diyAudio Member
 
Join Date: Apr 2009
Default Problem with Rotel RB-985 MKII 5 channel home cinema amplifier...

Hi,

I am looking for some advice. I recently owned a Rotel 985 MkII 5 channel home cinema amplifier for a number of years without fault.

However I recently changed my kit and sold the amplifier on ebay. When it arrived to the buyer he complained that 4 of the channels buzzed whilst the centre channel is in working condition (it left me in full working order)

I refunded the buyer and received the amplifier back and sure enough four of the channels will not play anything other than a buzz noise which gets louder as you turn up the volume of the input.

However, the centre channel works without fault.

I have had a look under the lid and all fuses are fine and no damage seems to have occurred to any electrical components, no cracks or damage to any of the circuit boards when you look down from the top.

Does anyone have any ideas to what the cause could be?

Many thanks in advance.

Paul
  Reply With Quote
Old 8th April 2009, 03:25 PM   #2
hoppaz is offline hoppaz  United Kingdom
diyAudio Member
 
Join Date: Apr 2009
... Just to add that if just a speaker is connected up to the amp it in either of the four faulty channels no buzz is heard it is only when you connect something to the rca input.

Also, there is no sound played through the faulty channels just a constant buzz. The guy who bought the item said it made his speakers make a loud rumbling sound.
  Reply With Quote
Old 9th April 2009, 08:04 AM   #3
hoppaz is offline hoppaz  United Kingdom
diyAudio Member
 
Join Date: Apr 2009
Anyone?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Crossover Advice for Home Cinema DIY RedCoat23 Multi-Way 10 7th July 2008 12:29 AM
Active Crossover and 7.1 Home Cinema Amp mikethomas79 Multi-Way 4 28th February 2008 01:53 PM
home cinema speakers skogs Multi-Way 6 7th September 2007 05:15 PM
TV/home cinema speakers Hay Introductions 1 6th January 2002 04:50 PM


New To Site? Need Help?

All times are GMT. The time now is 07:49 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2