Fuse for AI 500 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 13th February 2009, 01:46 PM   #1
Miotog is offline Miotog  United Kingdom
diyAudio Member
 
Join Date: Feb 2009
Question Fuse for AI 500

Hi Guys
Just joined the club and have to say how great it is.
Sorry for being such a wet but I have this audio innovations 500.
I always loved the sound as it was soo much better than transistor amps.
Problem is it has stopped working. The fuse below the three pin mains input connector is blown and I was wondering if anyone knows the specification. The fuse that was in there was a delay 2.5 amp and I replaced it with this spec and it too always blows.

Can anone confirm if I am putting the right fuse in (2.5amp seems low to me) and if the fuse is the right one what else do you think it may be??

Amp totally dead on switch on?????
Tried replacing valves but no good.

Awaiting some help from all you hio tech folk.....
Many thanks
Miotog
  Reply With Quote
Old 6th September 2012, 05:26 PM   #2
tony31 is offline tony31  France
diyAudio Member
 
Join Date: May 2007
hi
It is a 3.15 A

Tell me if it works

tony from France ;-)
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuse housing melting but fuse not blowing, ppi amp rawadia Car Audio 21 2nd August 2008 10:39 AM
SMD Fuse stef1777 Parts 2 26th April 2007 12:03 AM
Why main fuse and not rail fuse? digital desire Solid State 10 3rd December 2006 08:07 PM
amp rating for fuse and fuse holder? riotubes Parts 5 27th August 2006 03:10 AM


New To Site? Need Help?

All times are GMT. The time now is 03:28 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2