Mosfet Amplifier - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 28th January 2009, 12:46 PM   #1
diyAudio Member
 
Join Date: Jun 2007
Location: Whakatane, North Island
Default Mosfet Amplifier

Hello.

I'm still looking for a Schematic for the Hitachi HA6800 Mosfet
Power Amplifier. I really need it, as there are still a few burnt resistors that I need to know the values of.

In Return, I can offer Drawings / Manuals for many Denon, NAD,
and also a lot of Aiwa Manuals / Schematics.

Thanks, Telnet100.
  Reply With Quote
Old 28th January 2009, 01:56 PM   #2
lineup is offline lineup  Sweden
diyAudio Member
 
lineup's Avatar
 
Join Date: Dec 2005
Location: the north
Hitachi HA-6800 Integrated Amplifier Service Manual

this website, but probably you will have to pay
http://www.vintageaudiomanuals.com/-H-.htm
__________________
lineup
  Reply With Quote
Old 20th May 2012, 09:23 AM   #3
diyAudio Member
 
Join Date: Jun 2009
Sorry to dredge up an old thread, but I have the service manual for this amp if you would like a copy. Just send me a pm if interested
  Reply With Quote
Old 20th May 2012, 09:37 PM   #4
diyAudio Member
 
Join Date: Jun 2007
Location: Whakatane, North Island
Default Hitachi HA6800 Mosfet Amp

Thank You so much for that offer, but in the meantime, I have already managed to get a copy.
Thanks again!
  Reply With Quote
Old 8th August 2012, 09:53 PM   #5
diyAudio Member
 
Join Date: Mar 2011
Location: Germany
I just repaired a Hitachi HA-6800.

It first looked like a shortcut or burnt through MOSFETS, but ...

In both, left and right power amp, I found (the same) six defective fuse resistors on the main PCB.
R712 (220R, 1/4 Watt)
R714 (470R, 1/4 Watt)
R716 (82R, 1/4 Watt)
R717 (82R, 1/4 Watt)
R718 (470R, 1/4 Watt)
R720 (100R, 1/4 Watt)
They are all part of the current amplification stages.

No visual indication for defects with the resistors, some of them had changed values, most just interrupted.

All transistors, including the four MOSFETs, were OK.
After replacing the resistors, the amp worked again.

Relay cleaning and replacement of the lights.

Because of the serious heat from the 200mA idle current in each of the MOSFETs, one can assume that - over the years - most of the electrolytics have suffered and could use replacement.
I did so and was rewarded with excellent sound quality.

- Poetry2me
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MOSFET amplifier ash_dac Solid State 6 5th December 2006 08:55 AM
MOSFET/MOSFET amplifier jarek Pass Labs 21 22nd June 2004 05:04 PM
1kW MOSFET amplifier Kilowatt Solid State 207 28th March 2004 09:44 PM


New To Site? Need Help?

All times are GMT. The time now is 07:00 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2