Problem with Rotel RB850 - Page 3 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th January 2009, 04:00 PM   #21
rmsmax is offline rmsmax  United Kingdom
diyAudio Member
 
Join Date: Jan 2009
Mmmmm...you've given me lots to think about. I'm going to investigate and mend the amp. I am quite tempted to build a new front-end and house it in the RC850 case which is well made. This together with mods to my Marantz CD should keep me out of mischief for a few evenings!

Thanks all for your advice and info.....certainly got my grey matter going again!

Gavin
  Reply With Quote
Old 27th January 2009, 12:42 AM   #22
cfbuck is offline cfbuck  Canada
diyAudio Member
 
Join Date: Mar 2004
Location: London, Ontario
Default power and driver transistors

Quote:
homemodder wrote

thats the 2sd1047, 2sb817, 2sd600 and 2sb631
Hi Gavin,

I cannibalized what I think was a Rotel 870 integrated for the chassis. I believe I have the power and driver transistors listed above. I did however have a spark fly when I apparently shorted one of the power transistors to the heatsink during the deconstruction. All the others should be in the condition that they were. It was operational on both channels but had some fading problems so I think that the power transistors should be OK.I can take a picture if you want to be sure that they are the correct ones. I would give them to you for the price of the postage.

Cheers, Fred
__________________
Signature
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rotel RB850 transformer blown? rhiolly rub gt Solid State 5 16th April 2009 02:59 PM
Rotel RB850 Still Current? Schematic Included transducer Solid State 50 20th April 2008 12:36 AM
Rotel rb850 Leisner Solid State 54 4th October 2007 08:28 PM
Rotel RCC-955 Problem sorenj07 Digital Source 0 27th February 2007 01:51 AM
Rotel RA-931 problem njholland Solid State 3 16th July 2006 04:01 PM


New To Site? Need Help?

All times are GMT. The time now is 12:23 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2