Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

Yamaha A 720 switch problems
Yamaha A 720 switch problems
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 2nd January 2009, 04:33 AM   #1
Mike Star is offline Mike Star  Australia
diyAudio Member
 
Join Date: Dec 2008
Default Yamaha A 720 switch problems

Hi there,
I have a Yamaha A 720 Amplifier and it has problems with the switches. I was told that this was a common problem with the A 720 over time and that it was costly to repair and difficult to source the parts.
I really like this amplifier and would love to get the new or refrubed switch sets or have it repaired by someone who has the expertise.
Can anyone please help?
Thanks
  Reply With Quote
Old 2nd January 2009, 06:39 PM   #2
rocco gibralter is offline rocco gibralter  United Kingdom
Account disabled at member's request
 
Join Date: Aug 2008
http://www.audio-circuit.dk/index.ph...uals&Itemid=61

have a look at the service manual on there Mike, scroll down, Most manufacturers dont use exclusive switches /pots etc, so if you can find the offending items usually there is info in the switch, ratings, part numbers, etc, Then get replacements from component outlets..

Just a bit of detective work really...Good luck!
  Reply With Quote
Old 2nd January 2009, 06:40 PM   #3
rocco gibralter is offline rocco gibralter  United Kingdom
Account disabled at member's request
 
Join Date: Aug 2008
Info 'On' the switch........ beg pard!
  Reply With Quote

Reply


Yamaha A 720 switch problemsHide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Yamaha EMX 88S Powered Amp Problems room237 Solid State 6 12th December 2016 06:17 AM
yamaha mx 800 led problems please help dcperdue Solid State 14 18th April 2016 06:57 PM
Yamaha YST-SW60 Problems penguinpaul Subwoofers 2 13th July 2009 11:17 PM
Yamaha M 70 Problems - Please Help if you can Louisiana_Man54 Solid State 2 16th February 2009 03:02 PM
yamaha ax-640 problems roebas Solid State 0 4th May 2005 11:50 AM


New To Site? Need Help?

All times are GMT. The time now is 12:55 AM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright ©1999-2017 diyAudio
Wiki