Repair SMPS - Need help identifying SMD, schematic attached - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 24th December 2008, 12:01 AM   #1
diyAudio Member
 
Join Date: Oct 2007
Default Repair SMPS - Need help identifying SMD, schematic attached

Hello folks!
I need some help identifying a SMD transistor. Q119 on schematic.
Schematic of SMPS on Page 129 and 131. www.itxpress.se/433cmx.pdf

It says "YA" on top of the SMD transistor Q119.
And it is a SOT23 package or similar.
It should be a FET according to schematic.

On most sites i find that YA is a pnp wich is faulty according to schematic.

But then i found this site:
http://www.ginko.de/user/franz.hambe...mdcode/cy.html

It says YAs = BSS83P wich is a SIPMOS, could this be correct?
Maybe i can use BSS84? Dont know if this part is critical.

The reason i want to replace it is because it reads a low Ohm.
R133 are burnt and Q125 shorted, probably because Q119
failed. Anyone who can confirm or dismiss my theory?

Any help here would be great though!
  Reply With Quote
Old 24th December 2008, 12:12 AM   #2
diyAudio Member
 
scott wurcer's Avatar
 
Join Date: Jan 2004
Location: cambridge ma
You need to ID the maker, AFAIK the codes are only unique within one companies product line and should be on their datasheet. With some really tiny packages the ID is only on the strip carrier or shipping bag so you need the schematic.
__________________
"The question of who is right and who is wrong has seemed to me always too small to be worth a moment's thought, while the question of what is right and what is wrong has seemed all-important."
  Reply With Quote
Old 24th December 2008, 12:36 AM   #3
diyAudio Member
 
Join Date: Oct 2007
I posted a link to the schematic. It does not say what they are.
Just a schematic. I think pioneer bought the power board
from someone else to power PDP. All components on the
other schematics for the different boards is written out.

But not the Power Supply

What should i do?
  Reply With Quote
Old 24th December 2008, 01:47 AM   #4
Banned
 
Join Date: Apr 2005
Location: Stockholm
silversweden,
BSS83P and BSS84 are PMOS. You need NMOS.
  Reply With Quote
Old 24th December 2008, 02:26 AM   #5
diyAudio Member
 
Join Date: Oct 2007
I really cant find the original part number
Wich NMOS could i replace this with?
  Reply With Quote
Old 24th December 2008, 03:15 AM   #6
Banned
 
Join Date: Apr 2005
Location: Stockholm
silversweden,
I don`t think a part number exists. YA is probably just some kind of internal designation or production code.
Try some NMOS you can get.
  Reply With Quote
Old 24th December 2008, 03:30 AM   #7
diyAudio Member
 
Join Date: Oct 2007
Yippie! I found it =) i think. on this site, dont understand the language.
http://monitor.net.ru/forum/plasma-p...fo-114977.html

just saw what YA = 3LN01C wich is a NMOS

maybe they just suggested that part... dont know
  Reply With Quote
Old 24th December 2008, 03:46 AM   #8
Banned
 
Join Date: Apr 2005
Location: Stockholm
That`s a real audiophile-grade device.
  Reply With Quote
Old 24th December 2008, 03:51 AM   #9
diyAudio Member
 
Join Date: Oct 2007
okey but do you think it will work?
  Reply With Quote
Old 24th December 2008, 04:09 AM   #10
Banned
 
Join Date: Apr 2005
Location: Stockholm
It definitely will. My assumption was wrong, the marking is confirmed in the datasheet. It`s the device.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SMPS repair has me stumped PM650 Power Supplies 3 19th January 2009 10:56 PM
Nad 218 THX repair/faulty/schematic/etc IsakAlexander Solid State 0 27th July 2008 04:52 PM
Anyone ever repair the smps inside an Alpine V-Drive head unit? turbo_slug Car Audio 1 18th March 2008 09:42 PM
Capacitor choice for attached schematic kasra Tubes / Valves 11 17th February 2007 07:46 PM
Car poweramp SMPS repair TL594CN based design, help! Puggie Power Supplies 3 2nd August 2006 09:21 PM


New To Site? Need Help?

All times are GMT. The time now is 04:24 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2