denom pma250 amp faulty,but no faulty parts found please help - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 7th December 2008, 12:25 PM   #1
diyAudio Member
 
homertooties's Avatar
 
Join Date: Nov 2005
Location: suffolk
Smile denom pma250 amp faulty,but no faulty parts found please help

Hi everyone working on a faulty denon pma 250 mk 3

Speaker relay not swiching due to dc rails on output,disconnected emitter outputs on left channel output stage ,speaker relay works,

So far i have changed right channel output for left still same ,

taken out pre divers and tested with dmm (good)

removed drivers and tested(good)

Checked emitter resistors(good)

checked all resistors ,and signal diodes all same as right channel

Checked bias transistor and the pot same as right channel

At a loss anyone any ideas

Thankyou in advance
__________________
if you strip it for parts keep them for years as soon as you get rid you will want them .....................
  Reply With Quote
Old 7th December 2008, 03:58 PM   #2
diyAudio Member
 
Join Date: Nov 2008
dc-coupled pre-stage/end-stage ?
pre-amp giving dc as input to poweramp?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Faulty Sansui BA-F1 could use some help Netlist Solid State 26 16th February 2008 08:45 PM
faulty driver? testarossa2k Full Range 9 20th September 2007 10:11 PM
Faulty tube? matejS Tubes / Valves 8 30th August 2007 09:16 PM
Faulty Rotel-500 GlennMcClements Solid State 0 8th January 2007 01:02 PM
Kenwood KA-1100D (faulty) all parts available matski Swap Meet 3 30th October 2006 07:40 AM


New To Site? Need Help?

All times are GMT. The time now is 08:43 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2