Musical Fidelity problem - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 27th October 2008, 09:42 PM   #1
diyAudio Member
 
Join Date: Oct 2008
Default Musical Fidelity problem

i have a problem
just spent all day seting up a Musical Fidelity Elektra Musical Fidelity Elektra E30 Power Amplifier Meridian speakers no matter what i tried with Speakers leads and phono leads i get a distushion through the left Speaker swaped the Speaker around and still the same help
  Reply With Quote
Old 28th October 2008, 11:33 AM   #2
diyAudio Member
 
Join Date: Oct 2008
is this woth getting repaired
  Reply With Quote
Old 28th October 2008, 03:46 PM   #3
AMV8 is offline AMV8  United Kingdom
diyAudio Member
 
Join Date: Jan 2005
Location: near london
Hi

If you give more information some people here might be able help you.

You need to isolate which component is causing the problem. Is it the speaker, or the speaker leads or the power amp left channel or the interconnect lead. You seem to suggest it is not the speaker - I think. Try swapping channels one component at a time to see which component is causing the problem.

If you can isolate the faulty component anfd then give some details of the damaged component then someonne here might be able to help.

Don
  Reply With Quote
Old 28th October 2008, 05:36 PM   #4
diyAudio Member
 
Join Date: Oct 2008
thanks for your help don it seem to be Power Amplifier i think
  Reply With Quote
Old 29th October 2008, 09:31 AM   #5
AMV8 is offline AMV8  United Kingdom
diyAudio Member
 
Join Date: Jan 2005
Location: near london
Hi
Then the power amp is worth repairing.
There are some ex musical fidelity engineers around west london who may be able to help. If you have any problems e mail me, as we both live near London, and I will try to help.

Don
  Reply With Quote
Old 29th October 2008, 09:50 AM   #6
diyAudio Member
 
Join Date: Oct 2008
thanks for your help don i put it in a tv repair shop yesterday waiting for a quote i will let you know how i got on
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Musical Fidelity F16 problem/Schematic Smiffy Solid State 9 31st December 2013 03:25 PM
Musical Fidelity X10-D - changing tubes problem gsrai Tubes / Valves 17 30th March 2013 10:14 PM
Help needed with Musical Fidelity P270 II electrical problem dynoPort Solid State 12 17th May 2009 10:17 AM
Musical Fidelity B1 amp transformer problem. nairod156 Parts 2 26th May 2008 08:00 PM


New To Site? Need Help?

All times are GMT. The time now is 04:03 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2