quasar amplifier by dr bora 1000 watt - Page 7 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 16th August 2012, 08:31 AM   #61
diyAudio Member
 
Join Date: May 2005
Location: Cacak, Serbia
Nice results Joselito! Several people built it without any issues and it should work OK. What was the cause of your trouble with amp in the beginning? First you reported it is distorting and in a next post you are saying it sound nice and clear?!?!
__________________
Laonicus Chalcondyles : “Tryballos, Serbos, autem gentem esse totius orbis antiquissimam et maximam, compertum habeo...”
  Reply With Quote
Old 31st August 2012, 07:49 AM   #62
diyAudio Member
 
Join Date: Oct 2010
Engel,

The diode drawn is reverse or short circuit it should be otherwise.

Edwin
  Reply With Quote
Old 31st August 2012, 08:30 AM   #63
diyAudio Member
 
Join Date: Oct 2010
Sir Boraomega,

It was a power supply problem where my friend Edwin here had plugged the transformer to a 100 vac source instead of the 220 vac. With that condition the power amp is low voltage and perform poor with 1000 watt 8ohm load. With the right power source it drives the load strong and clear. Thank you for the brilliant design you shared to us.


Engel,

I used the original IRFP240 specified by Sir Boraomega and had no chance of locating the IRFP460s. My friend Edwin now is also building one for him, he is not yet registered in the forum. Thanks

Joselito
  Reply With Quote
Old 31st August 2012, 09:18 AM   #64
diyAudio Member
 
Join Date: Sep 2003
Location: Slovenia
Default IRFP250

Hi,

could you use IRFP250 instead of IRFP240? I have tons of IRFP250 available.

Thanks,

Borut
  Reply With Quote
Old 27th October 2013, 10:35 AM   #65
diyAudio Member
 
Join Date: Oct 2013
Quote:
Originally Posted by engel dela pena View Post
joselito,
sir bora noted not to use irfp460 to me because of parasitic oscillation issue,what fets you use?
how do you implement the diode is this right?
pls see attachment
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1000 watt amplifiers boxcustom Car Audio 32 31st May 2011 04:49 PM
Help With A 500 Watt subwoofer and a 1000 amp Bgpoet Solid State 2 30th December 2008 07:41 AM
bora techno amplifier power supply djronbxs Solid State 9 4th October 2008 01:35 AM
1000 Watt with usb input ! cph2000 Class D 1 4th October 2007 06:04 AM
NEW Dayton 1000 Watt Subwoofer Plate Amplifier - CHEAP! BHTX Swap Meet 0 28th December 2006 05:08 AM


New To Site? Need Help?

All times are GMT. The time now is 02:31 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2