Another burnt Nikko Alpha 230 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 26th September 2008, 01:30 AM   #1
ecoda is offline ecoda  Canada
diyAudio Member
 
Join Date: Mar 2007
Default Another burnt Nikko Alpha 230

I have found a coupe of similar threads but the schematic links are dead I am asking for some fresh help here.

Brief,
Nikko Alpha 230
No idea of its history
powers up as found with 1 fuse missing from its upper fuse bank (see photo 1)
no smells, no sounds
measure across empty fuse holder + 120vdc / 0vac
(yes I blew a fuse first)
measure 4 (front of case) transistors 2sa1169 - continuous
All remaining transistors mtd. to heat sink not open

Question,
Is this simply a question of changing over the open transistors, or is it likely a much bigger job.
Are these transistors substitutable?
Oh yes... any schematics floating around out there?

Thanks for any help.

Simon
Attached Images
File Type: jpg na230a.jpg (38.9 KB, 249 views)
  Reply With Quote
Old 28th November 2008, 04:24 AM   #2
diyAudio Member
 
Join Date: Nov 2008
Default Nikko Alpha 230 Schematic

I have similar situation and need the schematic.
Help please!

thanks a million.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nikko Alpha 220 HELP tombradvica Parts 4 7th May 2011 02:24 AM
Nikko Alpha 440 and 450 lazyjoe Solid State 0 3rd September 2008 10:00 PM
Nikko Alpha 220 GEirin Solid State 4 17th April 2008 08:34 PM
Nikko Alpha II amp troubleshooting livetoski Solid State 58 22nd February 2007 05:11 PM
Nikko Alpha 130 ecliptica Parts 1 29th January 2004 10:16 PM


New To Site? Need Help?

All times are GMT. The time now is 08:54 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2