Carver PM-1.5 Working but Protection Light On - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th September 2008, 10:15 PM   #1
diyAudio Member
 
Join Date: Sep 2008
Default Carver PM-1.5 Working but Protection Light On

Hey guys, I'm admittedly somewhat naive when it comes to the workings of power amplifiers. I know enough to understand how not to break it and how to use it properly, but when we start talking internal components, I don't know a whole lot. So I'm not looking for detailed repair instructions but rather thoughts/opinions on how serious the issue might be and possible causes.

So as the title of the post suggests, I have a Carver PM-1.5 power amp in my rig. Last night I powered it on and immediately the protection light came on. Oddly, both pilot lights came on as well and the amp appeared to be ready (it does not shutdown, or display any other signs of protection mode like the flashing pilot lights, audible sound, etc). Still I shut it down, tested everything (AC power, all cables, etc) yet I still get the same behavior. Upon further testing the amplifier itself seems to be working fine. If I send input to it, it works with no audible distortion or other audio issues.

From reading the manual for this amp, it sounds like the only time the protection light should come on is if the protection circuit engages at which point the amp would go into protection mode or shut down completely. Neither is happening so I'm curious as to what the issue might be. I'm assuming it would be a bad idea to continue operating the amp in this state. I'm looking for some expert opinions here.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Carver M-500t Protection Relay solderhead Solid State 24 30th September 2007 09:36 PM
Protection Circuit Issues Carver C-2 DreadPirate Solid State 10 1st October 2006 08:44 PM
Amp protection light on wally91chevrole Car Audio 3 27th December 2005 01:08 PM
Carver PM 1200 Protection light on, amp works! screamersusa Solid State 1 17th August 2005 01:51 AM


New To Site? Need Help?

All times are GMT. The time now is 09:55 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2