Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 18th August 2008, 07:40 AM   #1
diyAudio Member
 
Join Date: Aug 2008
Default soundcraftsmen pcr 800 schematics

hi im a beginner here ,but im lookin for info,schems,advices,mods of course,about the pcr800,i have a pm860 too thats fine and working,but the pcr turn on the led clip in chanel B at very low signal input so i dont use for that,i bought this amp as is,i have electronics skills and equipment so, if somebody can help....
thanks Arturo
artcarmo@gmail.com
  Reply With Quote
Old 19th August 2008, 04:59 AM   #2
diyAudio Member
 
Join Date: Aug 2008
I have some readings that may be help for the pcr800
DC at output B (bad one) -35mV
DC at output A -113mV
The PSU about +/- 64 (i have a ligth in series with ac mains) and +/- 13 .the chanel A its little warm than B . all this with no load and no signal at input.Thanks
  Reply With Quote
Old 21st August 2008, 07:37 AM   #3
diyAudio Member
 
Join Date: Aug 2008
Well since a have noting to loose....i swap the outputs and ,surprice, the problem goes to the channel A...looking in the forums (one post from stell4given) i notice that the clip sistem in the SC is very good ,and almost tll about something wrong in the output....i will test the hitachis tomorrow
  Reply With Quote
Old 21st August 2008, 06:06 PM   #4
diyAudio Member
 
Zero Cool's Avatar
 
Join Date: Sep 2004
Location: MN
email sent with the schematics.
  Reply With Quote
Old 21st August 2008, 07:24 PM   #5
diyAudio Member
 
zeonrider's Avatar
 
Join Date: Mar 2004
Location: Belgrade RS
Default Hi ZC!

Quote:
Originally posted by Zero Cool
email sent with the schematics.
Send me a copy!!OK!

Regards zeoN_Rider

linkxp@sezampro.yu
  Reply With Quote
Old 22nd August 2008, 06:51 AM   #6
diyAudio Member
 
Join Date: Aug 2008
Bad news...two K135 dead. thanks ZC for the useful information,i was looking around and i realize that you can help me ,i m very grateful....so im going to find the parts and post the results asap.
  Reply With Quote
Old 23rd August 2008, 02:19 PM   #7
diyAudio Member
 
Zero Cool's Avatar
 
Join Date: Sep 2004
Location: MN
Yup the 135's seem to die before the 50's do. which explains why i have extra stock of J50's and no 135's left!

make sure to check the gate limiting zener diode string. if that string dies, an over voltage will take out the mosfets!

Also you will not the lack of Drain/Source resistors in these amps! the mosfets should be carefully matched for best performance.

There was a guy here that was selling some new 135/J50 fets for a very good price.

Once you get the amp up and running, tell me what you think of it. I love these little amps. very smooth. never harsh, a little shy on the lowest octaves of bass but clean. these were rated better then the Adcom 555's of the day buy Audio magazine.


Zeonrider, email sent with the schematics.


Zc
  Reply With Quote
Old 23rd August 2008, 02:23 PM   #8
diyAudio Member
 
zeonrider's Avatar
 
Join Date: Mar 2004
Location: Belgrade RS
Zeonrider, email sent with the schematics.

Zc [/B][/QUOTE]


I, received thanks again!!!!

Regards zeoN_Rider
  Reply With Quote
Old 24th August 2008, 09:40 AM   #9
diyAudio Member
 
Join Date: Aug 2008
Thanks for the advice on zeners,yea hard to find the 135...any suggest for matching (if i find) i dont have any like "super criket " only a tester with hfe.... and i atach the procedure i use to test the mosfets.any other advice? thanks
Attached Files
File Type: txt mosfet_testing.txt (998 Bytes, 68 views)
  Reply With Quote
Old 26th August 2008, 06:42 AM   #10
diyAudio Member
 
Join Date: Aug 2008
Hi again still nothing about the 135's...any advice to find ? on semi have any like that? peavey deca's? thanks
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundcraftsmen 900X2 screamersusa Solid State 36 8th July 2012 08:57 AM
Soundcraftsmen Pre-amp enzedone Solid State 2 27th March 2007 01:07 AM
FS: Soundcraftsmen PM-840 410 watt amp $150.00 Zero Cool Swap Meet 0 27th May 2005 01:45 AM
Soundcraftsmen 220 mig-ru Tubes / Valves 2 16th July 2002 06:11 AM


New To Site? Need Help?

All times are GMT. The time now is 09:52 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2