NAD c-320 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th June 2008, 04:55 PM   #1
diyAudio Member
 
Join Date: Jun 2008
Send a message via MSN to yomartinmendoza
Default NAD c-320

HI guys

Here a NAD fan... or addict...

My NAD C-320 amplifier doesn't function...
Anyone can provide me a schematic to repair it?
Aparently kind of a shortcut problem

Thanks in advance

martin

martinmendel@gmail.com
  Reply With Quote
Old 19th June 2008, 08:45 PM   #2
Netlist is offline Netlist  Belgium
diyAudio Moderator Emeritus
 
Netlist's Avatar
 
Join Date: Jan 2003
nad c320

/Hugo
  Reply With Quote
Old 20th June 2008, 02:41 AM   #3
diyAudio Member
 
Join Date: Jun 2008
Send a message via MSN to yomartinmendoza
Default nad c-320

thanx hugo I am printing it now... hope to be able to solve the trouble....
Cheers
Martin
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



New To Site? Need Help?

All times are GMT. The time now is 04:37 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2