nad 3020 problems - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th May 2008, 09:03 PM   #1
diyAudio Member
 
Join Date: Aug 2006
Default nad 3020 problems

i have just aquired a nad 3020 and it sounds great, however it has a few problems firstly on switch on there is a thump sound over the speakers, and then there is a 69mv dc offset on the right channel and im unable to ajust with the pot (possibly faulty?)
any ideas, or help would be appricated.

schematics are here http://www.tcaas.btinternet.co.uk/index-4.htm

thanks
chris
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Another NAD 3020 jerryo Solid State 17 3rd May 2012 07:39 PM
NAD 3020 problem vubkevin Solid State 16 11th December 2007 02:08 PM
NAD 3020 amplifier volume problems Neilb Solid State 7 21st December 2006 12:44 AM
NAD 3020 hum rigadig Solid State 13 31st May 2004 10:33 PM
NAD 3020 problems Neopsp Solid State 2 17th May 2002 03:34 AM


New To Site? Need Help?

All times are GMT. The time now is 04:31 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2