Technics Suv 707 Kek - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Thread Tools Search this Thread
Old 17th May 2008, 06:52 PM   #1
diyAudio Member
Join Date: Feb 2008
Default Technics Suv 707 Kek

i have an technics suv707kek i switched it on and the yellow power light which normally powers to a red after a few seconds just started flashing amber rapidly.i know its a protection mechanism but not sure what has caused it.

any help would be appreciated.


  Reply With Quote


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Technics SA-600 ZigDaPig Solid State 0 16th August 2005 02:33 PM
Technics SU-Z22 Rob Flores Parts 0 18th March 2005 02:12 PM
Which Amp to keep - Technics or NAD? maxw Solid State 5 6th December 2004 11:41 AM
DJs and Technics davesaudio Analogue Source 2 3rd November 2004 02:46 AM
technics sl-23 ironfinger43 Analogue Source 0 29th May 2004 06:44 AM

New To Site? Need Help?

All times are GMT. The time now is 01:03 AM.

vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.
Copyright 1999-2015 diyAudio

Content Relevant URLs by vBSEO 3.3.2