Grundig A-9000 broken :( - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 4th May 2008, 02:48 PM   #1
mat_one is offline mat_one  Poland
diyAudio Member
 
Join Date: Mar 2005
Location: Poland
Default Grundig A-9000 broken :(

Hi.
I have bought broken Grundig A-9000. Have no idea how to repair it Maybe STK is dead? There is one burned resistor(RN13) on the main pcb.

I have service manual which can send to anyone who is intrested. Thanks in advance for any suggestions.
Attached Images
File Type: jpg burned.jpg (56.0 KB, 321 views)
  Reply With Quote
Old 12th June 2008, 07:39 PM   #2
ATRAC3 is offline ATRAC3  Macedonia
diyAudio Member
 
Join Date: Jun 2008
Send a message via MSN to ATRAC3
Why don't you try if there is voltage on the speaker outputs? Does the relay turn on?
  Reply With Quote
Old 12th June 2008, 07:45 PM   #3
mat_one is offline mat_one  Poland
diyAudio Member
 
Join Date: Mar 2005
Location: Poland
there is no voltage. actually i`m pretty sure, the reason is STK. in free time `ll replace STK and i hope it `ll helps.
  Reply With Quote
Old 12th June 2008, 07:47 PM   #4
mat_one is offline mat_one  Poland
diyAudio Member
 
Join Date: Mar 2005
Location: Poland
relay doesn`t work (cant hear any sound like that)
  Reply With Quote
Old 12th June 2008, 07:58 PM   #5
Zen Mod is offline Zen Mod  Serbia
diyAudio Member
 
Zen Mod's Avatar
 
Join Date: Jan 2003
Location: ancient Batsch , behind Iron Curtain
measure DC on outputs before relay ;

if it's present , there is just slight chance that STK isn't shot
__________________
my Papa is smarter than your Nelson !
clean thread; Cook Book;PSM LS Cook Book;Baby DiyA ;Mighty ZM's Bloggg;Papatreasure;Papa...© by Mighty ZM
  Reply With Quote
Old 12th June 2008, 08:49 PM   #6
mat_one is offline mat_one  Poland
diyAudio Member
 
Join Date: Mar 2005
Location: Poland
thank for clue. soon `ll check it and type the result.
  Reply With Quote
Old 16th June 2008, 06:19 AM   #7
diyAudio Member
 
Join Date: Jul 2003
Location: Dona paula, Goa
Measure input pins' voltages
If both measure nearly same, then the STK is good.
If u find this voltage is not close to zero, then check the resistor powering the input circuitry of the chip (will be around 100 ohms). This may be open.

Gajanan Phadte
  Reply With Quote
Old 16th June 2008, 09:06 PM   #8
ATRAC3 is offline ATRAC3  Macedonia
diyAudio Member
 
Join Date: Jun 2008
Send a message via MSN to ATRAC3
I guess that if the relay doesn't click (turn on) the STK is dead so the protection curcuit doesn't turn on the relay to protect the speakers. Or maybe the resistor that's burned was powering the protection curcuit and now it dowesn't power the relay... Anyway send me the manual to check it out
  Reply With Quote
Old 17th June 2008, 06:06 PM   #9
mat_one is offline mat_one  Poland
diyAudio Member
 
Join Date: Mar 2005
Location: Poland
Very thanks for all tips guys.
Actually i have no time to check all these options, but maybe firstly i should check the TP (Test Points to current idle) if there is any voltage. That ll be fast one. If there is voltage the reason should be STK.

Resistor on pic is burned, so i have to replace it. when solder it out, will check if it has connection between two ends. then one option ll be checked.

The scheme is available here: http://m2.xt.pl/grundigfineartsa9000.zip
  Reply With Quote
Old 26th November 2008, 02:01 PM   #10
kissn73 is offline kissn73  Hungary
diyAudio Member
 
Join Date: Nov 2008
Hi everybody!

Mat_one, you have written, you have the service manual (I think not only the schematic) for the Grundig A9000. If it is still available plese send it to my E-mail, or plese send a link where from I can download it. I have an A-9000 too, but it hase several errorrs. Without the service manual I can not repair. Only the shematic is not enough, because I have to check -for example the bias- in the power amplifier part.

Thank you for advance!
Best regards
Norbert
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rejuvenating+moding Grundig CD-9000 Bassivus Digital Source 15 18th March 2014 02:05 PM
Boxlight 9000 mfear84 Swap Meet 0 10th May 2006 11:09 PM
NAD 9000 Cartridge snoopyma Analogue Source 0 2nd September 2005 08:52 AM
SSL 9000 - Mic Preamp TobWen Solid State 15 28th November 2004 09:06 AM
DVP-S 9000 ES How is possible? Jesús Puerto Digital Source 1 29th November 2003 12:25 PM


New To Site? Need Help?

All times are GMT. The time now is 01:51 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2