Problem with Adcom GFP-555II - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st April 2008, 11:11 PM   #1
diyAudio Member
 
Join Date: Feb 2007
Location: Gulf Breeze, Florida
Default Problem with Adcom GFP-555II

I have a GFP-555II that has a problem.

I get a static-y noise in both speakers. If I tap the knob on volume pot it will go away with a slight pop. Sometimes it will not reappear until the unit is powered off and then back on.

When the static noise is not there it sounds just like new.

Any ideas what this might be? If the volume pot needs replacing are the parts available?

I am very fond of this unit and I would like to fix it myself if possible. I can imagine shipping it to be fixed almost wouldn't be worth it due to the weight.

Thanks a bunch!

-claiborne
  Reply With Quote
Old 22nd April 2008, 04:40 PM   #2
diyAudio Member
 
crippledchicken's Avatar
 
Join Date: Dec 2003
Location: south east mo.
I would try using some Caig Deoxit spray cleaner and see if that solves the problem first. good luck!
  Reply With Quote
Old 22nd April 2008, 06:50 PM   #3
diyAudio Member
 
Join Date: Feb 2007
Location: Gulf Breeze, Florida
I am about to make a parts order so I will add some Deoxit to it.

Tonight I will have finally enough time to put the unit on my bench and really go over it closely. Maybe I will see something else that could be causing the problem.

I was just wondering if this problem was something common to this model.

Thanks!


-claiborne
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adcom GFA-555II badfireguy Solid State 8 1st March 2012 06:02 AM
Adcom GFA-555II the apostate Solid State 32 2nd September 2011 09:41 AM
Adcom GFA-555II with DC Offset sjdemark Solid State 19 28th February 2009 02:33 PM
Adcom GFA-555II PS for sale oscarav098 Swap Meet 2 3rd December 2005 03:03 PM
Adcom GFA-555II problem oscarav098 Solid State 2 10th November 2005 04:47 PM


New To Site? Need Help?

All times are GMT. The time now is 09:13 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2