sansui g-7500 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 15th April 2008, 10:36 AM   #1
pezza89 is offline pezza89  Australia
diyAudio Member
 
Join Date: Sep 2007
Send a message via AIM to pezza89 Send a message via MSN to pezza89 Send a message via Yahoo to pezza89
Default sansui g-7500

hi all, have a strange issue with a sansui g-7500, powered it up, first time no sound, second time changed to speaker b, got sound from L channel only, 3rd time power it up - everything works - does it sound like a relay issue? vu meters worked on all occassions.

Also does anyone know where the usual rear protection fuse is and what kind of fuse is it for a 240v version! Cheers!
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sansui G-7500 schematic needed anatech Solid State 34 3rd December 2009 10:55 PM
Sansui G-7500 help needed 1978chevyman Solid State 3 15th April 2008 10:47 AM
Tuner Sansui Tu-717 & Tu-7500 oldmarantz Analogue Source 4 2nd November 2005 05:28 AM
Sansui g-7500? Jasmeleg Solid State 9 7th September 2005 08:36 PM
Onkyo DX-7500 Schematic culcanmar Digital Source 1 22nd February 2003 03:32 PM


New To Site? Need Help?

All times are GMT. The time now is 07:42 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2