EP2500 Schematics??? - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 5th March 2008, 01:14 AM   #1
diyAudio Member
 
Zero Cool's Avatar
 
Join Date: Sep 2004
Location: MN
Default EP2500 Schematics???

Anyone have Behringer EP2500 Schematics???


I have the QSC version but once upon a time i saw someone mention in a thread someplace they had the Behringer version
  Reply With Quote
Old 8th March 2008, 12:01 PM   #2
diyAudio Member
 
Join Date: Feb 2005
Location: Ýstanbul / TURKEY
Default Ep2500

There is Behringer Ep2500 schematic...

http://usera.imagecave.com/serhatkay/Ep2500.jpg
  Reply With Quote
Old 1st April 2008, 07:57 PM   #3
LAJ is offline LAJ  United States
diyAudio Member
 
Join Date: Mar 2008
Location: Atlanta Ga. USA
Default EP2500

I've just repaired one of these. It was blown up on both channels. But I think the reason was due to the fan not keeping up with the heat generated. Probably be best to replace the fan (24V) with one that has a higher velocity.
  Reply With Quote
Old 3rd April 2008, 03:36 PM   #4
LAJ is offline LAJ  United States
diyAudio Member
 
Join Date: Mar 2008
Location: Atlanta Ga. USA
The early 2500s had IRFZ44s in them for the step up FETs. The later ones had 50N06s. But QSC has a bulletin out on this (style of amp) and says the 50N06s should be replaced with 52N06s. But the package style is different and might not mount up well.
  Reply With Quote
Old 5th April 2008, 05:11 PM   #5
LAJ is offline LAJ  United States
diyAudio Member
 
Join Date: Mar 2008
Location: Atlanta Ga. USA
Be careful with your soldering as these are multilayer boards (5 layers I think). You do not want to pull out a via and lose connectivity to an inner layer circuit.
If your bias pots go open after a failure, 13 ohms seems about right for a fixed resistor to set the proper bias of 80mv across R2 or R106 (Ch1/Ch2).
  Reply With Quote
Old 5th April 2008, 08:43 PM   #6
diyAudio Member
 
Zero Cool's Avatar
 
Join Date: Sep 2004
Location: MN
I just repaired one as well. the 15V zener diode went bad causing the amp to lock up and it took out the triac crowbar output the Fet, all the output transistors, the emitter resistors, base resistors, and just about every other component in that section. But, With the help of the QSC service manual, i was able to get it back up and running pretty easily.

The current fold back test is a bugger however. shorting the output of the amp to check for current foldback then recovery at full power into a 2 ohm load requires a BIG resistor bank!


Zc
  Reply With Quote
Old 7th April 2008, 08:42 PM   #7
LAJ is offline LAJ  United States
diyAudio Member
 
Join Date: Mar 2008
Location: Atlanta Ga. USA
Default ep2500

There are four 15V zeners (two for each channel) located on the Ch2 board. My zeners were OK but both 4580s were blown sinking the + & - 15 supplies. Thats because they're DC coupled to the output stage.
I'm surprised Behringer didn't put some glue on those pots. Those bass notes at some high energy concerts are sure to make them "creep".
And the fan needs to be turned around so it pulls cool air in from the front (the filter is on the inside of the front panel). With the fan sucking from the back, it will fill up with dust and you wouldn't know that the back of the filter is clogged.
  Reply With Quote
Old 16th March 2010, 12:18 AM   #8
diyAudio Member
 
Join Date: Jan 2010
Default one channel low vol on ep-2500 beringer HELP ?

the preamp section checks ok.i have signal in and out of ic 4 and 5.voltage looks ood on all transistors? maybe a couping cap is bad? any ideas where to look?
please
  Reply With Quote
Old 16th March 2010, 12:19 AM   #9
diyAudio Member
 
Join Date: Jan 2010
Default one channel low vol on ep-2500 beringer HELP ?

please respond to me directly at strat1953@aol.com
  Reply With Quote
Old 6th January 2011, 09:57 PM   #10
diyAudio Member
 
lorylaci's Avatar
 
Join Date: Aug 2008
Location: Dabas, Hungary
Send a message via MSN to lorylaci
Could someone post a pictutre about a PCB from bottom and from top, please?
It would be really helpful.
__________________
Olyan nem volt még, hogy ne lett volna valahogy
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
EP2500 issues LightwaveDude Parts 1 4th January 2009 04:31 PM
Behringer ep2500 amp adlaic Solid State 18 31st August 2007 05:46 PM


New To Site? Need Help?

All times are GMT. The time now is 11:37 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright ©1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2