Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 29th February 2008, 03:09 AM   #1
diyAudio Member
 
Join Date: Feb 2008
Default Marantz SR7400

I have a Marantz SR7400 receiver that is having a few problems. When I turn the receiver on, it comes on, clicks a few times and then turns off. The display will not come on either. I have been led to believe that there may be something wrong with the power supply circuit. I have the receiver apart but don't know where to begin. I have had some electronic experience in Engineering Physics class. But that has been a few years ago and I am a little rusty. Any help would be gladly appreciated.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Marantz PM-50 Amp Russell Solid State 2 7th March 2008 04:48 AM
Marantz CD 40 dongorgan Digital Source 1 9th October 2007 06:23 AM
Fix my Marantz richie00boy Digital Source 23 19th April 2006 12:14 PM
Right speakers for Marantz PM8000 + Marantz CD67-OSE? betto80 Multi-Way 2 24th May 2005 03:21 PM
Link Between Marantz CD12 and Marantz CD99 Mesh Digital Source 16 7th November 2003 06:08 PM


New To Site? Need Help?

All times are GMT. The time now is 05:43 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2