Sick Peavey IPS800 amplifier - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st February 2008, 11:03 PM   #1
diyAudio Member
 
Join Date: Nov 2002
Default Sick Peavey IPS800 amplifier

I have a IPS800 that was working fine when I turned it off and when I powered it up again it has both power lights alternating off and on and I hear a relay clicking.

Anyone have any ideas? schematic?
  Reply With Quote
Old 24th April 2008, 11:42 AM   #2
diyAudio Member
 
Join Date: Nov 2002
Anyone?
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Got this on this on ebay..sick amp benny_rx_blanco Car Audio 2 8th April 2009 10:18 PM
New sick amplifier Solosound Car Audio 3 5th December 2008 01:29 AM
My Linn Axis is Sick. Please help fix bubbamc119 Analogue Source 53 26th January 2008 12:08 AM
Help - Z4 sick on startup BeaufortRalph Pass Labs 5 18th April 2005 06:50 PM
peavey cs800 power amplifier bong Solid State 2 28th November 2002 07:06 AM


New To Site? Need Help?

All times are GMT. The time now is 04:31 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2