Go Back   Home > Forums > >
Home Forums Rules Articles diyAudio Store Blogs Gallery Wiki Register Donations FAQ Calendar Search Today's Posts Mark Forums Read

Solid State Talk all about solid state amplification.

No power / repeated blown fuse in Sony STR-D915
No power / repeated blown fuse in Sony STR-D915
Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 21st January 2008, 09:37 AM   #1
dmworking247 is offline dmworking247  Australia
diyAudio Member
 
Join Date: Jan 2008
Default No power / repeated blown fuse in Sony STR-D915

Hi all,

I'm new to diyaudio. I build, collect and repair arcade machines and generally like building/repairing just about everything, but I have no specialties in audio equipment.

Recently I've been given a Sony STR-D915 audio/video control center for a jukebox project, which has no power (it has a blown fuse).

The guy who gave it to me said that he opened it up and could see a burned fuse... so he took the fuse in, got a replacement, put it in and it burned out immediately.

I'm a little unsure whether he might have just been given the wrong fuse, or whether the transformer is faulty or something else... all guess work without better resources.

I'd love some help to diagnose this little problem but I'm not even sure which section it goes in (I'm audio-ignorant, you might say

So here I am to introduce myself and learn my way around

Thanks everyone,
- Dale
  Reply With Quote

Reply


No power / repeated blown fuse in Sony STR-D915Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blown fuse when power on without connections internally hew128 Digital Line Level 9 30th August 2009 05:18 AM
Please help: no sound and blown fuse spendorspain Tubes / Valves 6 11th December 2008 02:48 PM
EAD Power Master 1000, Blown fuse ??? pixworld Solid State 1 8th June 2008 08:00 PM
ETI480 blown fuse... bezel6 Solid State 1 30th November 2005 12:25 AM
Blown fuse!!! StalfoS Chip Amps 13 4th June 2005 01:10 PM


New To Site? Need Help?

All times are GMT. The time now is 09:42 PM.


Search Engine Optimisation provided by DragonByte SEO (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Resources saved on this page: MySQL 16.67%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Copyright ©1999-2018 diyAudio
Wiki