Need help with NAD C350, protection! - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 19th January 2008, 07:47 AM   #1
diyAudio Member
 
Join Date: Oct 2007
Default Need help with NAD C350, protection!

Hi! I may be of topic but i didnt now where to put this,

I recently got my hands on a NAD C350 integrated amp.
(home stereo).

But the amp goes in protection after 2-3 seconds.

I have checked the output transistors and they seeme to
be OK.

And i checked the drivers, and the seeme to be ok.
A litle hard to measure because the have mirrored
the pins on that transistor modell.

I removed all the drivers and started the amp.
And i got green light!

But what the hell? I measured them and there is no
short from what i can se. they all measure about 0.6 in
diod check, and same for the outputs.

Anyone have a clue what could be the problem?

I saw inside the case that signal earth had been repaired
for a couple of years ago. And i saw a fixed print. But cant
find anything that looks broken.

But you can se that the board is a bit darker around
the drivers and then there is 3 other transistors.
But none of them seemes to have a short.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting NAD C350 RobHance Solid State 16 17th September 2011 02:56 AM
Nad C350 burbeck Solid State 0 18th December 2007 02:32 PM
looking for a nad c350 schematic neurot Solid State 0 4th December 2006 06:29 PM
Tweak/mod NAD C350 Pound0sound Chip Amps 7 27th February 2004 10:49 AM
Tweak/Mod NAD C350 Pound0sound Solid State 0 9th February 2004 03:01 PM


New To Site? Need Help?

All times are GMT. The time now is 04:51 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2