Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 17th December 2007, 02:41 PM   #1
Culdy is offline Culdy  United Kingdom
diyAudio Member
 
Join Date: Dec 2007
Default PIONEER XV-DV313 blown amp (s/c)

The woofer amplifier has blown due to feed pair pulling out and shorting together. Output buzzes only. Speaker tests OK. Inside, there doesn't appear to be any replaceable fuse protection. I'd be grateful for advice on repair. Thanks.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blown backlight on Pioneer DEQ 99 MikeHunt79 Car Audio 1 23rd July 2009 05:30 PM
Pioneer HT receiver... blown channel? infinitesymph Solid State 13 17th February 2008 10:50 PM
mtx blown please help ADRIANd Car Audio 32 30th September 2006 11:35 PM


New To Site? Need Help?

All times are GMT. The time now is 11:01 AM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2