Mitsubishi da-a15 - diyAudio
Go Back   Home > Forums > Amplifiers > Solid State

Solid State Talk all about solid state amplification.

Please consider donating to help us continue to serve you.

Ads on/off / Custom Title / More PMs / More album space / Advanced printing & mass image saving
Reply
 
Thread Tools Search this Thread
Old 8th December 2007, 03:56 PM   #1
diyAudio Member
 
Join Date: Mar 2007
Question Mitsubishi da-a15

My friends,

Recently I bought a mitsubishi da-a15 dual mono contruction and impressive looks

But I'm facing a problem, I've replacing all electrolitic caps, termal paste on the transistors, but while the amplifier is playing suddenly starts to have distortion in one channel and some times in both channels but after a few seconds goes away but after half hour it returns.

My question is, since the big 12000uf capacitators are those I haven't replace, do you think they can be the cause for that (I forgot to say but before startin g to restore it already had this problem), or maybe is the power or output transistors?


If anyone could help me ...thankx
  Reply With Quote
Old 8th December 2007, 08:46 PM   #2
tvi is offline tvi  Australia
diyAudio Member
 
tvi's Avatar
 
Join Date: Apr 2001
Location: Moonee Ponds, Vic, Australia
Could be the output relays?

I have the Service manual somewhere, if you need a copy I might be able to help.

You can see what this guy ddid to restore a DA-A10 here

Hope this helps

Regards
James
__________________
The small part of ignorance that we arrange and classify we give the name of knowledge.
Ambrose Bierce
  Reply With Quote
Old 9th December 2007, 07:00 AM   #3
djk is offline djk
diyAudio Member
 
djk's Avatar
 
Join Date: Feb 2001
Location: USA
It's probably a relay problem.

Good luck finding those dual caps, they were made special for these amps. From your description it doesn't sound like they are bad, I would add some bypass caps (as shown in the photos).
__________________
Candidates for the Darwin Award should not read this author.
  Reply With Quote

Reply


Hide this!Advertise here!
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mitsubishi HD1000u Mitch_eich Swap Meet 0 29th June 2008 12:15 AM
Mitsubishi tapedeck gain wire Parts 2 28th February 2007 09:59 AM


New To Site? Need Help?

All times are GMT. The time now is 08:36 PM.


vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 1999-2014 diyAudio

Content Relevant URLs by vBSEO 3.3.2